1

I have a side-by-side installation of Windows 8.1 and Ubuntu. As I am a pretty helpless user it took me some time to set it up, but it worked and when I start the computer, I get a choice between running the Ubuntu or, if I type "esc" and enter "exit", it jumps to Windows and starts Windows. Today I was asked to update the Linux files. I did, and when I returned after a minute or so Windows was up. ???? I restarted the computer, but now only Windows starts. It is as if Linux never existed - in fact something prevents that the system asks for the choice. Is there something I can change to recover my Ubuntu partition? After I tried to repair GRUB (as given in comment below) I get the following boot loader menu, and I include what happens when I choose any of the options:

Ubuntu => black screen, caps lock blinking, nothing happens anymore no matter which key I press

Advanced options for Ubuntu => same without caps lock blinking

Windows EFI bootmgfw.efi => Windows starts regularly.

Windows EFI Boot UEFI loader => Windows starts regularly

EFI/Ubuntu/fwupx64.efi => the boot loader page is entered again

EFI/Ubuntu/mx64.efi => blue screen “shim UEFI key management” appears, when I press “any key to continue”, another menu “Continue boot/enroll key from disk/enroll hash from disk”, when I choose 'continue boot', black screen as above

EFI/Toshiba/Boot/bootmgfw.efi => black screen as above

Windows Boot Manager => Windows starts regularly

System setup => "error: can’t find command 'fwsetup'. Press any key to continue" => back to boot loader page.

When I start Windows (8.1) and go to the Windows Boot manager, under "using a device" Ubuntu is listed as one option. Choosing this option leads again to the Ubuntu boot manager, so nothing is gained.

The boot repair diagnosis can be found at http://paste.ubuntu.com/p/qv42scvngD/

  • How have you determined the Ubuntu partition isn't there? – Elder Geek Mar 3 '18 at 21:19
  • I guess it's physically "there" - but as I wrote above, the page where I can choose which OS to start does not appear. – Heimdal Mar 6 '18 at 20:22
0

Windows usually won't typically see an Ubuntu partition as Windows doesn't support as many filesystems as Ubuntu does. This is especially true of the default ext4 filesystem as well as many others. To the best of my extensive knowledge, the only partition types that Windows recognizes on desktop OS's are FAT variants or NTFS. Regardless, it sounds to me like you've somehow lost your boot record or grub configuration. This is in my experience far more likely to happen via a Windows update than any Ubuntu update. (I've seen the former, but never the latter.) To resolve this issue you simply need to repair grub or reinstall grub.

  • Here is what happened: – Heimdal Mar 6 '18 at 21:26
  • Here is what happened: I made a liveUSB with Ubuntu. From this I could run Ubuntu, of course, but felt helpless to repair GRUB (when I entered the recommended commands in the terminal I got an error message). So I created a Bootrepair with the help of UnetBootin. After I ran it with "recommended repair", I got back the page from which I can choose what to boot. Unfortunately, when I choose the first option, "Ubuntu", the screen turns black and my "Caps Lock" LED starts to blink. Then nothing more happens. Choosing the "advanced Ubuntu" is the same without a blinking LED. I can start Windows. – Heimdal Mar 6 '18 at 21:35
  • Error messages are the gift no one wants (except us). Please edit your post to include what you did, and exactly what happened including the error. To make this easier I recommend using script which can log your commands and the output to a file which you can either copy and paste into your question or post to paste.ubuntu.com and provide us with a link. – Elder Geek Mar 7 '18 at 17:26
  • As to why your Caps Lock LED is blinking that's very likely another question that would require more details on your hardware than you have provided to answer properly. [a pastie]paste.ubuntu.com of the output of sudo lshw would be likely to help with that. – Elder Geek Mar 7 '18 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.