6

I realize this gets reported a fair amount but I've searched as much as I can and nothing appears to be helping. After doing an update last night, I logged in today and cannot see the launcher or menu bar. When I open a terminal window, the title bar at the top is cut off, so I suspect that there might be something scaling-related. It could be:

  1. that the launcher and menu bar are no longer there
  2. the launcher and menu bar are there, but beyond the borders of the laptop screen.

When I get to the login screen, I can see the menu bar with the time, battery display, wifi, etc.

When I log in to a guest account, the launcher and menu bar appear.

Here are the things that I've tried so far:

  1. sudo apt-get update
    sudo apt-get install --reinstall ubuntu-desktop
    sudo apt-get install unity
    sudo shutdown -r now
    
  2. sudo apt-get install dconf-tools
    dconf reset -f /org/compiz/
    setsid unity
    

    (when I run these steps, I get a brief resize of the desktop, then it seems stuck on "unity7 start/running, process 8299")

  3. mv ~/.config ~/.config_backup
    
  4. rm -rf .compiz-1
    
  5. sudo apt-get install dconf-tools
    dconf reset -f /org/compiz/
    setsid unity
    
  6. dconf reset /com/ubuntu/user-interface/scale-factor
    
  7. sudo apt-get install dconf-editor
    dconf-editor
    
    open path com -> ubuntu -> user-interface cannot change the scale factor, it doesn't allow me to enter a numeric value
  8. unity --reset (screen briefly resizes, then goes back to "normal")
    
  9. initctl restart unity-panel-service
    
  10. The steps given here: https://www.youtube.com/watch?v=WeCs_gIey6c although I don't get the dialog boxes about "resolving conflicts"

Everything has been followed with a reboot.

5
3

OK Guys, I have found the solution posted in another forum and it works for me and at least two others - very simple. Open a terminal by right clicking on the background then type in this command: sudo -r ~/.cache then reboot.

2
  • This did indeed work. Thanks Erica! Actually, I had to type in "sudo rm -R ~/.cache" but it nonetheless worked anyways. Mar 10 '18 at 15:26
  • 1
    @lengthy_preamble since the command provided isn't the command you used and you accepted it I think it would be wise to edit this answer with the command that you actually used. Although to be honest I'm baffled that this worked for you.
    – Elder Geek
    Mar 13 '18 at 17:39
3

Please try removing .cache directory on Home:

rm -rf ~/.cache
1
  • executing this command and then rebooting fixed the problem for me! Jun 19 '20 at 12:26
0

As per this accepted answer, try:

rm -rf ~/.config/compiz-1/compizconfig/*
sudo reboot

Your step #4 isn't exactly the same thing. For example:

rick@alien:~$ locate ~/.config/compiz-1/compizconfig/*
/home/rick/.config/compiz-1/compizconfig/config
/home/rick/.config/compiz-1/compizconfig/done_upgrades
───────────────────────────────────────────────────────────────────────────────
rick@alien:~$ rm -rf .compiz-1 # Your step 4)
───────────────────────────────────────────────────────────────────────────────
rick@alien:~$ locate ~/.config/compiz-1/compizconfig/*
/home/rick/.config/compiz-1/compizconfig/config
/home/rick/.config/compiz-1/compizconfig/done_upgrades

The compiz files in question are still there.

4
  • Hello WinEunuuchs2Unix, I tried the above step exactly as written and unfortunately there has been no change, even with a reboot. Oddly enough, I've noticed that I can't resize the borders of any windows or even alt-tab. Very strange. Mar 3 '18 at 18:55
  • @lengthy_preamble That user's update was dated Feb 16/2018 so it could be your update is a different problem altogether. The lack of Alt+Tab support and window resizing was not mentioned in other posts that I can recall. Mar 3 '18 at 18:57
  • Thank you for trying. For the time being, I have created a new user and hopefully I can get enough work done that way. Hopefully someone will have some other suggestions, though... Mar 3 '18 at 19:01
  • @lengthy_preamble The new user account (or a guest session) is the one thing in common I've seen working in other posts. So there are certainly similarities. I'll keep looking... Mar 3 '18 at 19:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.