3

I'm trying to setup a Ubuntu server and running in to a problem setting up a static IP.

My OS is as below:

Distributor ID: Ubuntu
Description:    Ubuntu 17.10
Release:        17.10
Codename:       artful

My 01-netcfg.yaml is below:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp5s0f0:
      dhcp4: no
      addresses: [192.168.0.109/24]
      gateway4: 192.168.0.1
      nameservers:
        adresses: [8.8.8.8,8.8.4.4]

When running sudo netplan apply I get the below error. Same error when running debug.

Error in network definition //etc/netplan/01-netcfg.yaml line 9 column 8: unknown key adresses

All my google attempts for a correct .yaml file says this should work. What am I doing wrong?

  • NetworkManager instead of networkd may be more appropriate. See Configuration in the Netplan wiki. – noobninja Mar 10 '18 at 15:32
5

I believe it is telling you that it doesn't understand adresses. Please try:

addresses: [8.8.8.8,8.8.4.4]

Follow with:

sudo netplan apply

Any improvement?

  • That worked! That was just plain stupid of me, was blindly checking on "nameservers:" since the error said it was that line that was wrong :D Thank you for the help! – Sandoz Mar 3 '18 at 16:51
1

This is a netplan joke. You must read your error message

Error in network definition //etc/netplan/01-netcfg.yaml line 9 column 8: unknown key adresses

as "there is a section on line 9 (here nameservers) and in this section (in some line below, but surely not the line 9) is a keyword (key) adresses which is unknown.

And now the message is clear and the solution is straightforward.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.