2

I know there is a lot of topics around this issue, but now it's strange since Bluetooth seems to /should work. When I do

sudo service bluetooth status

I get the following result which seems to be working (I put directly the image so one can check the green highlights)

result from sudo service bluetooth status

But on settings->bluetooth

enter image description here

the result of command hcitool dev is empty, i.e.

Devices:

and the result of hcitool scan is

Device is not available: No such device

How can I activate the Bluetoth in settings?

4
  • What is the output of hcitool dev and hcitool scan (add output to question)? – N0rbert Mar 3 '18 at 14:15
  • @N0rbert done it – João Pimentel Ferreira Mar 3 '18 at 14:27
  • 1
    So it is not bug. Ubuntu did not find your Bluetooth hardware. Do you have any? Add output of lsmod | grep blue, rfkill list and lspci -vvv | grep -A10 -i "bluetooth\|wireless\|network" to question. – N0rbert Mar 3 '18 at 14:33
  • 1
    Also need to edit question to add results from terminal for lsusb; dmesg | egrep -i 'blue|firm' – Jeremy31 Mar 4 '18 at 16:01
0

I was checking in the Internet and found a similar issue. I solved thus my problem with a very simple and brute way.

Go to Ubuntu Software Centre and search with keyword "Bluetooth". Then install everything :) I know, it's stupid and brute, but it worked for me and never had problems again.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.