0

Every now and then when working with Ubuntu 16.04.3 LTS a strange thing happens: it suddenly looks as if the view was slightly 'zoomed in', i.e., not all of the screen-content is visible any more, and the resolution is suddenly ever so slighly blurred. Moreover, while the touchpad still works, but when using it, the whole view is 'panned'/shifted in the opposite direction of my movement on the touchpad.

I don't know how to end this state other than by a complete reboot. I also don't know what triggers this strange state of the operating system.

Question. Is this a bug or a feature, and how can one turn this off again without resorting to restarting the system?

  • So, does this happen when you press a combination of keys or something? It seems like when you enter that mode you're using some kind of virtual desktop resolution. What is your graphics card? Did you install compizconfig-settings-manager or ubuntu-tweak? – devius Mar 3 '18 at 9:06
  • Saying 'for s in $(lspci | grep VGA | awk '{print$1}'); do lspci -v $s; done' results in the graphic card being described thus: "VGA compatible controller: NVIDIA Corporation Device 1c60 (rev a1) (prog-if 00 [VGA controller]) Subsystem: CLEVO/KAPOK Computer Device 67b4 Flags: bus master, fast devsel, latency 0, IRQ 131 Memory at db0000000 (32-bit, non-prefetchable) [size=16M] Memory at b0000000 (64-bit, prefetchable) [size=256m] Memory at c0000000 (64-bit, prefetchable) [size=32M] I/O ports at e000 [size=128] [virtual] Expansion ROM at 000c0000 [disabled][size=128K]... (running out of space) – guest Mar 3 '18 at 10:25
  • @devius: neither compizconfig-settings-manager or ubuntu-tweak were consciously installed by me; should I try, and what should I do if they are? – guest Mar 3 '18 at 10:26
  • Can you check this answer and see if you have enabled Enhanced Zoom Desktop? – devius Mar 3 '18 at 12:47
0

By accident, I today found a solution (for my very particular issue).

This might be useful to someone else (for this zooming-feature can be almost crippling to your work-flow when you don't know how to turn it off again). The solution was found randomly: today I accidentally but consciously did the hand-move which triggers the zooming, and I had the presence of mind of stopping to think of what I did and how to reverse it, and will describe it now.

The facts of the matter are the following:

  • In Ubuntu Version

    Ubuntu 16.04.3 LTS

release 16.04, Codename xenial, on my system, the following is true:

if I hold down the Alt key and simultaneously put exactly two fingers on the touchpad, then sliding the fingers towards the keyboard results in a zoom-in effect, while sliding the fingers away from the keyboard results in a zoom-out effect. The zoom-effect persists after taking all fingers away from the machine (this is the reason why this feature can be crippling: if you do this zooming-in move accidentally, and don't know how to reverse it, then you'll have to work with a heavily zoomed view, which slows you down significantly).

Notably, I tried this on another machine having Ubuntu 16.04.4 LTS installed; there, nothing happens if I do the above-mentioned moves. The versions differ by 1 only, and it seems that in the newer version this interesting though dangerous feature was removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.