0

Issue - WiFi works sometimes and sometimes it does not. My computer keeps trying to connect to WiFi before giving up (when it is not working). The network is up as my other devices successfully connect to it.

I have a TP-LINK TL-WN725N Ver:2.0 in addition to the inbuilt wireless card on my laptop. The same error is true for both the external and internal wireless cards.

The solution given here - Ubuntu GNOME 17.04: wi-fi not working -- mac address keeps changing? used to work and had me satisfied for a month or so but that work around hasn't been working for the last couple of weeks inspite of restarting network-manager.

I ran this in my terminal when connected via ethernet -

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && \
chmod +x wireless-info && \
./wireless-info

And got the following results - http://paste.ubuntu.com/p/NcBb6XWY3D/

Would love some help in this regard. Thank you.

1

In my experience, you will always have trouble if there are two drivers and two interfaces active and competing at the same time. I suggest that you blacklist the more troublesome of the two and eliminate this competition. From the terminal:

sudo -i
echo “blacklist rt2800pci”  >>  /etc/modprobe.d/blacklist.conf
modprobe -r rt2800pci
exit

Next, we see this in your scan:

 Cell 01 - Address: <MAC 'Pratyush' [AC1]>
                     ESSID:"Pratyush"
                     Protocol:IEEE 802.11bgn
                     Mode:Master
                     Frequency:2.412 GHz (Channel 1)
                     Encryption key:on
                     Bit Rates:300 Mb/s
                     Extra:wpa_ie=dd1a0050f20101000050f20202000050f2020050f20401000050f202
                     IE: WPA Version 1
                         Group Cipher : TKIP
                         Pairwise Ciphers (2) : TKIP CCMP
                         Authentication Suites (1) : PSK
                     Extra:rsn_ie=30180100000fac020200000fac02000fac040100000fac020000
                     IE: IEEE 802.11i/WPA2 Version 1
                         Group Cipher : TKIP
                         Pairwise Ciphers (2) : TKIP CCMP
                         Authentication Suites (1) : PSK
                     Quality=100/100  Signal level=100/100

Many Linux drivers hate TKIP. Moreover, most Linux drivers hate automatic selection between WPA and WPA2.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

After these changes, reboot the computer. Any improvement?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.