2

So I have an old macbook pro intel core duo 32 bits, UEFI 32 bits.

I bought a new SSD drive, and replaced the old drive.

I managed to make an EFI 32 bits bootable USB with the Lubuntun 17.10 ISO (using this guide).

I plug the USB key on the macbook pro, I turn it on while pressing on the Alt key, and I can see the option to boot on the USB EFI.

Lubuntu live is ready about 2 minutes later.

I open GParted and I create on the internal SSD drive an ESP FAT32 bootable partition (1GB) and the remaining is a ext4 partition.

I launch the Lubuntu installer, I pick "other", I install / on the ext4 partition.

At the end, the installer says grub-install failed, I have the option to skip the boot loader install, and the installation is over.

Of course, when I reboot the computer, it doesn't boot on Lubuntu.

So I boot again on the USB key. This time I install rEFInd as I read somewhere that could work.

sudo apt-add-repository ppa:rodsmith/refind
sudo apt-get update
sudo apt-get install refind

I choose to install on ESP. It installs a couple of things on the ESP partition of the SSD internal drive, including a nice looking XXXX32.efi file, which makes me think rEFInd installed the right 32 bits efi.

But when I reboot my computer, nothing, the boot from the internal hard drive is not possible.

Now I think I need help, any ideas?

[EDIT 1] Since my first post, I tried boot-repair. I booted from the live lubuntu 32 bits USB, I installed and launched boot-repair. It installed successfully coupke of files on the ESP partition, and told me in the end my boot was successfully repaired. Unfortunately when I boot the macbook, it's not possible to boot from the internal hard drive.

I also tried to make a USB key with rEFInd installed (as explained in this page, downloaded the binary .zip, extracted it, and run bash refind-install --usedefault /dev/sdd1 --alldrivers). The USB key works fine on my other computers, but it's not detected on my old macbook pro...

Again out of ideas. It seems to be a macbook thing, these things I've done would have probably worked on 32 bits PCs but, maybe the macbook firmware requires something else I don't know...

3

So finally I got it working with rEFInd.

The solution I will expose is a sequel to everything I did and described in the question, so read it before reading this.

So, I have a SSD with an (empty/broken) ESP partition, and Lubuntu installed on the remaining of the SSD, as an ext4 partition.

Before populating the ESP partition, I will first create an rEFInd USB key. That's a very useful tool to have when you're in trouvle, not only for this install, but in many situations. It allows you to boot your internal drives when the boot loader is HS.

So to create the rEFInd USB key :

From a random linux install

  • Plug and format your USB key as FAT32
  • Let's say the USB key first and only partition is /dev/sd**x**1
  • Download the rEFInd binary zip ( example https://sourceforge.net/projects/refind/files/0.11.2/refind-bin-0.11.2.zip/download )
  • Unzip, and open a terminal in the extracted folder
  • Type : sudo bash refind-install --usedefault /dev/sdx1 --alldrivers
  • This USB key will work/boot on most computers already, but not on my old macbook, you need to do a small rename job in the key's folders.
  • Go to /EFI/BOOT (key), and duplicate the xxxx32.efi file into boot.efi (simple rename could work, didn't test).
  • So in the end you should have a file with this path in your key : /EFI/BOOT/boot.efi
  • Try to plug the key in the macbook pro, reboot while pressing the ALT key, and you should see the option to boot on the key.

From here, you should be able to pick your internal ubuntu install, and boot it.

Once the internal ubuntu has booted, mount the ESP partition, remove everything (if you already try a few things), and copy ALL the files of the USB key in this partition.

Remove the key, reboot, and the macbook pro should boot from the internal drive with rEFInd (after showing the infamous ? folder for a couple of seconds).

Note that at one point, I also mounted the ESP partition as /boot/efi manually in the /etc/fstab file of my ubuntu install (if you read my question you'll see the lubuntu installer had failed to install the boot loader, that's why the ESP partition was empty and not mounted on the /etc/fstab file). Not sure if it's necessary or not.

Note also that I tried several times (as said in the Question) to install rEFInd from the bootable lubuntu ISO key (which would have avoid to use the trick with the rEFInd USB key). Theorically that should be possible. I tried to rename the xxx32.efi files into boot.efi after installing, and I tried several options like --alldrivers when installing rEFInd, but nothing worked (I'm not absolutely sure I did the -alldrivers test correctly, I should do it again to be sure, but I don't want to ruin it again). In the end the only thing that worked was copying the files from the rEFind USB key into the ESP partition of the internal drive...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.