0

I'm new to the forum. Have little experience with Ubuntu.

I needed to install an epson scanner and a scanner program. I managed to make the scanner program xsane and iscan work. These did not suffice for the work I have so I bought Vuescan in order the do my work on this platform. (I'm going to scan a lot of slides).

Vuescan did not work immediately. It reported some problems with the libstdc++.so.6 (.21 and .20 versions?)

I tried to fix the problems using first the desktop installer system. This was not possible. I kept getting errors and were not able to get a long this way.

I reverted to terminal and used apt-get different ways tracing solutions I found on the net.

Then I happened to install wrong version of the libstdc++ (for amd64) in place of the intel version i need. My mistake.

I tried different things to remove and reinstall the old version. Latest I have copied the ubuntu 14.04 intel versions of the libstdc++.so.6 and -.so.5 files into the /usr/lib/x86_64-linux-gnu/. Library.

What I see when I boot is: ubuntu fails to start the desktop. It reaches the login prompt and tries to start the desktop but reverts to the login prompt. I can start a terminal on ctrl alt f4. This gives some error messages. If I try to start apt-get I get similar errors: apt-get: error while loading shared libraries: libstdc++.so.6 invalid ELF header.

What can I do to locate the problem. What can I do to make the desktop to start. It keeps reverting to the login prompt.

  • Have you tried reinstalling libstdc++ from a shell via apt-get -f install; apt-get install --reinstall libstdc++6? – dsstorefile1 Mar 2 '18 at 21:07
  • Yes. I cannot use apt-get because it just gives me the message: apt-get: error while loading shared libraries: libstdc++.so.6 invalid ELF header. – Mich Mar 2 '18 at 22:37
  • Exactly what does: "Invalid ELF header" imply? – Mich Mar 2 '18 at 23:32
1

In such case you need to download libstdc++6 package manually and install it:

wget http://mirrors.kernel.org/ubuntu/pool/main/g/gcc-4.8/libstdc++6_4.8.4-2ubuntu1~14.04.4_i386.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/g/gcc-4.8/libstdc++6_4.8.4-2ubuntu1~14.04.4_amd64.deb
sudo dpkg -i --force-all libstdc++6_4.8.4-2ubuntu1~14.04.4_i386.deb
sudo dpkg -i --force-all libstdc++6_4.8.4-2ubuntu1~14.04.4_amd64.deb

Then continue as usual

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install -f
  • As noted in my question, it is an intel 64 bit machine. My fault was that I used an advice similar to the advice you give here, and this way made my problem escalate. ;o) I have tried to download and install the intel versions of libstdc++6, but the problem is that I cannot use apt-get. (As I have noted above). – Mich Mar 2 '18 at 22:40
  • I guess the amd64 version does not fit with the intel64? – Mich Mar 2 '18 at 22:48
  • amd64 and "intel64" both mean 64-bit. – dsstorefile1 Mar 2 '18 at 23:34
  • 1
    No, 64-bit is 64-bit for the most part. As N0rbert says in the answer, use dpkg to patch up libstdc++ so that apt works. – dsstorefile1 Mar 3 '18 at 1:13
  • 1
    Then using the apt-get procedure made things up to date. Later I realized that recent version of vuescan uses a version of the gcc++ not supported by ubuntu 14.04. I downgraded to a previous version (from 9.6.06 down to version 9.4.67) This removed all my problems. – Mich Mar 3 '18 at 20:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.