1

I'm running 16.04.4LTS server as a host for virtualbox-5.2 and have added xfce4 as a desktop environment for the techs to xRDP to. This works fine in all instances except passing keystrokes to the virtualbox management GUI.

When logged on locally, keystrokes appear as expected in the VirtualBox GUI. When logged on via xRDP, keystrokes appear as expected in all other applications that I've tested. When logged on via xRDP and using VirtualBox GUI (management not individual VMs), keystrokes generate unexpected characters. Below is an excerpt of the mapping:

a -> a
s -> b
d -> f
f -> h
g -> j
h -> k
j -> ;
k -> '
l -> `
5 -> backspace
alt left -> 5

I have reinstalled xRDP and tried both xfce4 and LXDE desktop environments. The same behaviour is exhibited in both. I have also tried a clean install of 16.04.4 Just to remove doubt I tried a keyboard remap. This didn't work although i didn't expect it to as only VirtualBox seems to be affected by this issue.

Does anyone have any suggestions on this?

  • Could you try connection from Remmina? In my experience it is the best for connection to VRDP. – N0rbert Mar 2 '18 at 12:55
  • this is discussing using xRDP to connect to the host machine, not the VMs themselves. I haven't actually tested VRDP yet...will let you know how that goes – eto.ttnflt Mar 2 '18 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.