"Newer releases of Ubuntu have newer releases of glibc."
The NEWEST (at time of posting) release of Ubuntu is 18.04 Bionic Beaver which contains glibc version 2.27 (which is a much HIGHER version number than 2.5). So upgrading to the very newest version of Ubuntu is not going to solve the problem. In fact the version of glibc on 16.04 Xenial Xeris 2.23 is a much HIGHER version number than 2.5 which should really have been numbered 2.05.
Visiting the page
glibc 2.5 was released 2006-09-29
glibc 2.23 was released 2016-02-19
glibc 2.27 was released 2018-02-01
The last one above (2.27) is the latest release and is present in 18.04 Bionic Beaver.
As Knud Larsen has pointed out, glibc-2.5 is a very old version, and thus installing it as a default on a 16.04 would result in a completely broken system.
"a piece of backup software says it needs "On Linux, glibc 2.5 or higher is required."
I suspect that you are trying to run a binary executable (rather than actually building from source) and that the backup software was designed and released for Red Hat (and RPM based) systems. This backup software would not happen to be BRU [home edition] perchance?
So the first lesson is, do not try to mix software built for RPM and different libc on Debian/Ubuntu/Mint and other derivative systems.
If you really, really, want to try something and this will only work if you run the wrong libc program NOT as root, you could try building from the libc source from the archive on the GNU source repository, install into /opt/something and then use LD_LIBRARY_PATH to point there before trying to launch the backup software. Of course if it has a GUI which may well be GTK (version 1 as opposed to GTK-2) it is never going to work because trying to build GTK (version 1) library if you can find the source is near impossible on modern systems.
The solution most probabe to get the ancient backup software to work is going to be get a copy of Red Hat Linux desktop or Centos or Mandriva or whatever for 2005/2006, see for example
install into a virtual machine, and then run your ancient backup software in an OS of vintage for which it was designed.
A better working alternative would be to look at a GPL open source up to date backup software server (amanda or cinder perhaps), or if you have money to spend, I see Tolis Group (the current owners of BRU) now charges USD 400 for a Linux workstation edition. Of course other commercial alternatives are available, but the best option is, of course, something which is GPL open source and requires zero cash payment.
Additional thoughts --
You are 100% certain it says "glibc 2.5 or higher is required." and not "glib 2.50 or higher is required" ? Ubuntu 16.04 has glib 2.48 whereas Ubuntu 18.04 has 2.56.
If it is really saying glibc, then your program is broken anyways because it does not accept that glibc 2.27 is a HIGHER version than glibc 2.5 and thus meets the test of "2.5 or higher".