2

I'm running Ubuntu 16.04 LTS in a server environment, and a piece of backup software says it needs "On Linux, glibc 2.5 or higher is required." I've run ldd --version and get ldd (Ubuntu GLIBC 2.23-0ubuntu10) 2.23 back, so currently it doesn't work.

I'm running a mysqldump script at the moment to back them up as files, but would like the sql backup to run instead.

I think the package name is libc6 so ran the following:

apt-cache depends libc6
libc6
  Depends: libgcc1
  Breaks: <hurd>
  Breaks: libtirpc1
  Breaks: locales
  Breaks: locales-all
  Breaks: lsb-core
  Breaks: nscd
  Suggests: glibc-doc
 |Suggests: debconf
  Suggests: <debconf-2.0>
    cdebconf
    debconf
  Suggests: locales
    locales-all:i386
    locales-all
  Replaces: <libc6-amd64>

I gather I can upgrade the version with some other repo or compiling it, but am concerned with what this might break in ubuntu and if it's at all recommended? Is there a safe way to install this?

  • 1
    Umm... 23 > 5 surely? what is the software, and how exactly is it failing? – steeldriver Mar 1 '18 at 23:24
  • 1
    16.04 is two years old, and includes a two-year-old glibc. Newer releases of Ubuntu have newer releases of glibc. Altering or replacing the Ubuntu-provided version of glibc is recommend for EXPERTS only - a great deal of breakage may happen, and we don't provide support for that. – user535733 Mar 2 '18 at 0:35
  • 1
    Could you please add a little more detail? What exactly did you do, what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster Mar 2 '18 at 9:52
  • glibc-2.5 : Released year 2006. – Knud Larsen Mar 2 '18 at 12:27
3

"Newer releases of Ubuntu have newer releases of glibc."

The NEWEST (at time of posting) release of Ubuntu is 18.04 Bionic Beaver which contains glibc version 2.27 (which is a much HIGHER version number than 2.5). So upgrading to the very newest version of Ubuntu is not going to solve the problem. In fact the version of glibc on 16.04 Xenial Xeris 2.23 is a much HIGHER version number than 2.5 which should really have been numbered 2.05.

Visiting the page

https://sourceware.org/glibc/wiki/Glibc%20Timeline

reveals

glibc 2.5 was released 2006-09-29

glibc 2.23 was released 2016-02-19

glibc 2.27 was released 2018-02-01

The last one above (2.27) is the latest release and is present in 18.04 Bionic Beaver.

As Knud Larsen has pointed out, glibc-2.5 is a very old version, and thus installing it as a default on a 16.04 would result in a completely broken system.

"a piece of backup software says it needs "On Linux, glibc 2.5 or higher is required."

I suspect that you are trying to run a binary executable (rather than actually building from source) and that the backup software was designed and released for Red Hat (and RPM based) systems. This backup software would not happen to be BRU [home edition] perchance?

So the first lesson is, do not try to mix software built for RPM and different libc on Debian/Ubuntu/Mint and other derivative systems.

If you really, really, want to try something and this will only work if you run the wrong libc program NOT as root, you could try building from the libc source from the archive on the GNU source repository, install into /opt/something and then use LD_LIBRARY_PATH to point there before trying to launch the backup software. Of course if it has a GUI which may well be GTK (version 1 as opposed to GTK-2) it is never going to work because trying to build GTK (version 1) library if you can find the source is near impossible on modern systems.

The solution most probabe to get the ancient backup software to work is going to be get a copy of Red Hat Linux desktop or Centos or Mandriva or whatever for 2005/2006, see for example

https://old-linux.com/

install into a virtual machine, and then run your ancient backup software in an OS of vintage for which it was designed.

A better working alternative would be to look at a GPL open source up to date backup software server (amanda or cinder perhaps), or if you have money to spend, I see Tolis Group (the current owners of BRU) now charges USD 400 for a Linux workstation edition. Of course other commercial alternatives are available, but the best option is, of course, something which is GPL open source and requires zero cash payment.

Additional thoughts --

You are 100% certain it says "glibc 2.5 or higher is required." and not "glib 2.50 or higher is required" ? Ubuntu 16.04 has glib 2.48 whereas Ubuntu 18.04 has 2.56.

If it is really saying glibc, then your program is broken anyways because it does not accept that glibc 2.27 is a HIGHER version than glibc 2.5 and thus meets the test of "2.5 or higher".

  • 2
    I'm fairly sure OP means 2.25. I'm having a similar issue where Ruby 2.6 requires GLIBC_2.25, but I only have 2.23 installed. Bit of a head scratcher. – dearsina Sep 4 '19 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.