0

My os is Ubuntu 16.04 LTS. I installed apache2 from ubuntu repositories. After applying this command:

sudo systemctl enable apache2

I get following error:

apache2.service is not a native service, redirecting to systemd-sysv-install Executing /lib/systemd/systemd-sysv-install enable apache2

Which is not satisfying me at all. These commands are executed without any problems:

sudo systemctl restart apache2 
sudo systemctl start apache2

journalctl -ex and apache2ctl configtest say nothing.

journalctl -ex output:
бер 01 21:24:47 medion-laptop NetworkManager[917]: <info>  [1519932287.3295]   lease time 7200
    бер 01 21:24:47 medion-laptop NetworkManager[917]: <info>  [1519932287.3298]   nameserver '192.168.0.1'
    бер 01 21:24:47 medion-laptop NetworkManager[917]: <info>  [1519932287.3300] dhcp4 (wlp8s0): state changed bound -> bound
    бер 01 21:24:47 medion-laptop dbus[908]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-d
    бер 01 21:24:47 medion-laptop systemd[1]: Starting Network Manager Script Dispatcher Service...
    -- Subject: Unit NetworkManager-dispatcher.service has begun start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- 
Unit NetworkManager-dispatcher.service has begun starting up.
    бер 01 21:24:47 medion-laptop dbus[908]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
    бер 01 21:24:47 medion-laptop nm-dispatcher[8011]: req:1 'dhcp4-change' [wlp8s0]: new request (1 scripts)
    бер 01 21:24:47 medion-laptop nm-dispatcher[8011]: req:1 'dhcp4-change' [wlp8s0]: start running ordered scripts...
    бер 01 21:24:47 medion-laptop systemd[1]: Started Network Manager Script Dispatcher Service.
    -- Subject: Unit NetworkManager-dispatcher.service has finished start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit NetworkManager-dispatcher.service has finished starting up.
    -- 
    -- The start-up result is done.
    бер 01 21:24:47 medion-laptop dhclient[1073]: bound to 192.168.0.102 -- renewal in 2970 seconds.
    бер 01 21:33:40 medion-laptop org.gnome.evolution.dataserver.Sources5[1711]: ** (evolution-source-registry:1911): WARNING **: secret_service_search_sy


medion@medion-laptop:~$ apache2ctl configtest
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Syntax OK

Also I tried to reinstall my apache2 (like here), but the error still come up.

So after searching about this issue, I found out that this problem usually appear when the configuration file has syntax error. But I don't have anything like that, probably cause I have installed my apache2 a few minutes ago and never had a deal with apache2's configuration file.

0

Is apache running? This error does not reflect any issue with apache itself, but it is informing you that even though you used a systemd command to enable the service, it's actually invoking a SysVinit style script. Provided apache is running correctly you can safely ignore this error.

1

This is not an error but an information that Ubuntu 16.04 still uses a SysV init style file to start Apache, and systemd just wraps that.

From /lib/systemd/systemd-sysv-install:

# This script is called by "systemctl enable/disable" when the given unit is a
# SysV init.d script. It needs to call the distribution's mechanism for
# enabling/disabling those, such as chkconfig, update-rc.d, or similar.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.