I work with a Thinkpad X220 and have Xubuntu 11.10 installed. Everything works fine, except for this;

When I suspend my laptop, while it is connected to my external monitor (either cloned screen or only using the external monitor), it gives a blank screen when coming out of suspend. I can still see my mouse moving, but both screens remain blank.

Only a hard reset fixes the issue. Returning it to suspend (by closing laptop) does nothing. Both screens remain inactive (black, but with mouse pointer) after wakeup from suspend/sleep.

Some further information;

A) I have memorized the "Display settings" command. When I press the command sequence on my keyboard to 1) show only laptop screen and then 2) show only the external screen, my display (on the external monitor) returns and I can proceed as normal. But I have to do this every time, and when I make one mistake I am lost (as I cannot see the output unless I do it completely right).

B) I have now installed the gui interface "grandr" and edited to e.g. show only my external monitor or a dual screen setup (depending on my preferences). Now, when I put my laptop to sleep/suspend, both displays work normally (dual or only single external display) after resuming from sleep or suspend. - So I guess the is sort of a solution, but it requires you to install grandr and not to use the Xubuntu display settings menu.

Maybe someone has a better solution or fix?

  • My x220 and T61 are experiencing exactly the same problem! I'll try your methods later. By chance, I tried out a couple of distros. I found Ubuntu, Mint and LMDE all have this problem, while fedora 16 does not. So I kind of feel it is related with the default settings or video driver of Debian based linux. Hopefully someone could help figure out the real problem. – user49370 Mar 6 '12 at 0:26

Multi-monitor support upgraded in Ubuntu 12.04 beta1. I tried out the live CD. suspend/resume works flawlessly.

  • Indeed, under Xubuntu 12.04 I no longer experience this issue. Great, thanks developers! – Treepata Jul 11 '12 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.