0

I've got a Ubuntu VM running on a server where I VPN into it using windows RDP. I get to the xcfe4 desktop but its really laggy. I dont have access to HyperV or the server so I am stuck with putty for SSH sessions and the RDP on Windows. From what I saw when the Ubuntu VM was set up the normal ubuntu desktop ran just fine so it may be my xrdp settings? Anyone got any ideas on how to improve the speed of the remote connection? Thanks guys

  • Could you maybe bridge your network connection for the VM? Maybe you can VNC directly to the VM instead of running two different GUIs in one RDP that might be causing your slow down. – Terrance Feb 28 '18 at 15:29
2

Could it be that the connection is just slow? You could try to reduce the amount of data by reducing the screen resolution, color depth and quality.

How to achieve this depends on the program you use for the RDP connection. If you use the windows remote desktop program you have click on the little arrow on the lower left to edit the settings (display and performance tab)

| improve this answer | |
  • Hi thanks for the reply, ive treied to change the display settings in Windows RDC, its on full screen at the minute and 32 bit color. If i change the settings the session fails and either the XRDP desktop view of Ubuntu will be in grey or it will flash grey and quite remote desktop connection. Do I need to reflect the changes in xrdp.ini configuration file? I think you might be right about the slow speed. How do you adjust the resolution and quality, is that done in Ubuntu or can i do it through SSH on the xrdp.ini file? thanks – cfcorp Feb 28 '18 at 16:08
  • The resolution and the color depth are set by the client. You do not have to change the client configuration (i.e. xrdp.ini). I do not know where the new issues come from. – mbeyss Mar 1 '18 at 8:52
  • Thanks. Much better for me! – nmDat Aug 9 at 4:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.