3

This question already has an answer here:

I have a problem with compiz since a recent update, it uses 160 to 170% of cpu according to top, the laptop's fan is going full speed. And it goes up with time, after 30 minutes it's over 270%.

Here's the apt log from when it started: https://pastebin.com/giJsZsDj

About my laptop, it has 16GB RAM, Intel® Core™ i7-6700HQ CPU @ 2.60GHz × 8 processor, a Quadro M1000M graphic card and running 64-bits ubuntu 16.04.1 LTS.

I can see with nvidia-smi that compiz is using the graphic cards (another member here had issues with their drivers).

Changing options from CCSM did not solve the issue.

Any idea how to fix this?

EDIT: Tried metacity --replace to temporarily use something else than compiz, but compiz keeps on running anyway even if I try to kill it before.

None of the answers marked as duplicate help me in any way, it seems to be a completely different issue (no more related to those 3 or 5 years old you mentioned).

marked as duplicate by user535733, Eric Carvalho, Zanna, Eliah Kagan, Elder Geek Mar 7 '18 at 17:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you tried booting with a previous kernel version? – WinEunuuchs2Unix Feb 28 '18 at 12:35
  • I tried on 4.13.0-26 and 4.13.0-32 and same issue, compiz goes straight to 160% cpu after booting – Shugah Feb 28 '18 at 12:47
  • I tried to change these options via CCSM but it didn't work either – Shugah Feb 28 '18 at 13:24