0

total newbie here.

I have a slight issue, recently switched over to an ubuntu server (version 16.04.3) and am not having any luck in setting up the network interface. I have tried the same configuration in the desktop version and have been able to successfully connect, but on the server version, no luck. Need a static ip. DHCP doesnt seem to be working anyway.

I have trawled through countless forum posts, and havent been able to get the damn thing to work. Any help and advice is greatly appreciated.

Thanks in advance-Mat

13
  • Have a look at help.ubuntu.com/lts/serverguide/network-configuration.html Also you can't use DHCP if you want static (DHCP=dynamic...) Your answer will be in the the Static IP Address Assignment section
    – guiverc
    Feb 28 '18 at 10:03
  • Thanks, but i have already tried that. No luck. I have configured /etc/network/interfaces with my home networks ports, and still nothing has changed.
    – m.beck2120
    Feb 28 '18 at 10:07
  • Did you restart networking to force-read of change? (using the ifdown/ifup.. .. if=interface)
    – guiverc
    Feb 28 '18 at 10:13
  • 1
    Yes, even tried rebooting
    – m.beck2120
    Feb 28 '18 at 10:13
  • Back to basics - is your network interface recognized? (ifconfig ;sudo lshw -C network) or more importantly if tried manually entering commands to set IP address; ping your router, ping 8.8.8.8 (or whatever web address you use) what worked?? (ie. confirming there is no problem except configuration; also name as doc assumed eth0 was name but that may not be your interfaces name)
    – guiverc
    Feb 28 '18 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.