After clicking 'Install' button, I have this screen. How to install Skype on Ubuntu from Ubuntu's package manager? I've installed Skype manually by downloading it, but can't update it after that - Skype suddenly says Update only with package manager.

enter image description here

Upd 1:

enter image description here

  • Go to the Ubuntu Dash and search for "Software & Updates". Open it up and then go to the "Other Software" tab. Do you see anything with skype (eg https://repo.skype.com/deb stable main) listed? If so, what is the address listed?
    – Jaydin
    Feb 28, 2018 at 9:16
  • If you've installed it manually - what way to install it did you use ? Deb ? Snap ? Feb 28, 2018 at 9:37
  • @JayDin, Yes, I have that line there. But what do you mean address listed? Where may I see it? I have added a screenshot to question
    – Green
    Feb 28, 2018 at 10:01
  • @RobertRiedl, I don't remember for sure now, but apparently it was deb because I don't know what snap is.
    – Green
    Feb 28, 2018 at 10:08

1 Answer 1


In the first photo, it seems that you try to install skype as a snap package from the gnome software. You said that you installed skype manually by downloading it, but you didn't say if you got the snap version or the deb version.

From the second photo, I assume that since the repo of skype is there, you installed the deb version.
Given that, the problem is that the repo of skype, as illustrated in second photo, is disabled.
You have to enable it in order to get updates.

For clarification, check my repolist including skype repo: Skype repo enabled.

NOTE: the skype package in the repo is named skypeforlinux : Skype package in the repo

  • 1
    The first part of your answer didn't work out. I enabled Skype repo in "Software & Updates" but Ubuntu kept throwing error. The second part solved the issue. I installed Skype by $ sudo apt-get install skypeforlinux
    – Green
    Feb 28, 2018 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .