I have just installed Ubuntu 11.10 on my computer, and everything seems to run great. Well, almost. At log on, I can select from the settings the Ubuntu desktop (not ubuntu 2d).

Compiz configuration manager didn't seem to be doing anything to my unity 3d desktop. So, just to check, I run:


Sure enough it tells me I'm running unity 2d. Does the fact that 3d wont run mean that my video driver will not support unity 3d?

I have an Intel 945GME chipset, and tried to find information about drivers, but any fixes and workarounds all seemed to be for older versions of ubuntu, and did not work (or I didn't do it right, I am after all a new linux user).

After messing around with all that, I did a fresh install and just tried again to see if compiz settings manager would do anything, but I can't get Unity 3d to work. To describe my process the second time around:

First do a fresh install, then as soon as that's done install the following:

sudo add-apt-repository ppa:paullo612/unityshell-rotated
sudo apt-get update
sudo apt-get install unityshell-rotated libnux-1.0-0 compizconfig-settings-manager

I wanted to intall the unity rotated plugin (I can't stand having the launcher on the left side for some reason, but I really like the concept of the launcher, and don't really want to switch to gnome, which also didn't look right when I tried it). But neither unity rotated nor unity 3d are going to work for me if I have an issue with my hardware or drivers, will they?

If it is a video card driver/hardware issue, its not showing in normal use. Viewing of flash videos isn't as good as it was when I was running windows on this machine, but its not bad. Maybe just a little bit streaky. Not enough to really bother me a lot. My video card is certainly working to that extent, but it can do better.

There are no additional drivers that ubuntu finds for my computer at all.

Running unity_support_test results in these errors:

nathan@Vaio:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string:  2.1 Mesa 7.11

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  no
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

So far, my card still doesn't work. It seems strange Devius, that your computer all of a sudden works. I am running Kernel 3.0.0-15.

Maybe this can help somebody solve this issue: Maybe my graphics card is not configured? There is no xorg.conf file in its proper directory -- should there be? Supposedly the file is supposed to be there, but on my system, its simply missing

All of the software sources are enabled in the software center.

So, I am reaching out to the linux community. Any suggestions?

  • May be a dumb question: Have you tried opening up the 'Additional drivers' window and seeing if there's anything available? Also, if you open up a terminal and run "unity --replace" what does it say?
    – Alex
    Feb 3, 2012 at 8:49
  • Take a look at this question and edit your question to include that info.
    – jokerdino
    Feb 4, 2012 at 6:31
  • I remember a few weeks ago that my 945GME system also couldn't login into a (3D) Unity session, but apparently as of today it can. Running the unity_support_test on that system returns "yes" for all the tests. Kernel is version 3.0.0-15. Let me know if you need more info.
    – devius
    Feb 12, 2012 at 19:45
  • I think you need to enable more software sources at the Ubuntu Software Center (oneiric-updates, oneiric-security, oneiric-proposed) in order to get the latest kernel versions for 11.10.
    – Alexandre
    Feb 18, 2012 at 0:31
  • This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :)
    – Seth
    Dec 28, 2012 at 3:55

5 Answers 5


Make sure that xserver-xorg-video-intel is installed.

After that, you should be able to purge the ones you're not using, without uninstalling xorg. To see what video drivers you have installed, use something like:

dpkg -l | grep xorg-video


I have also an Intel® 965GM graphics card and Unity 3D works perfectly wity my system. However, my system info was showing my graphics card as unknown in Ubuntu 11.10 when I freshly installed it, and after a while (a few days later I installed Ubuntu 11.10) my Unity 3D was broken. I could be able to select "Ubuntu" but it acted like I was using Unity 2D.

I found out that it is related to OpenGL and I applied this command:

1.Remove NVidia drivers

(I know you didn't install any NVidia drivers, I also didn't install but in my case there were NVidia drivers installed somehow.)

sudo apt-get purge nvidia*

2.Remove your xorg.conf

sudo rm /etc/X11/xorg.conf

3.Reinstall xorg completely

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

4.Re-configure Xorg

sudo dpkg-reconfigure xserver-xorg

5.Restart your computer

sudo reboot

After I applied all of these commands, my Unity 3D was back and when I check system info, this time Ubuntu recognized my Intel graphics. Such problems occur with Intel graphics.

  • Unfortunately this did not solve the issue. The Unity-3d-test still results in not software rendered, and not GLX texture from bitmap. Still can't run Ubuntu 3d.
    – Nathan
    Feb 28, 2012 at 15:29
  • Then it seems as if you will not be able to run Unity 3D with that Intel 945GM graphics card. As a last question: When you check System Info under System Settings, is your graphics card recognized or is it still listed as unknown? Mar 2, 2012 at 0:18
  • Yes, it says 'VESA: Intel(r) 82945GM Chipset Family Graphics' under System Info > Graphics.
    – Nathan
    Mar 3, 2012 at 13:53

It might help to update the graphic drivers, those from the official repositories might be outdated. To update, just open a terminal console and enter

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get upgrade

Afterwards, restart your machine. I hope this helps


If you really want unity 3D to work. You can force it to run.
Be warned though, it will be a little buggy.

copy this in the terminal

sudo gedit /etc/environment

And then add this in the next line


Then save the file and reboot



If you have an external monitor plugged in then you may not be able to use unity 3d if the combined virtual screen size is > 2048 pixels due to hardware limitations of the chipset. If you have an external monitor plugged in then try it without (or set it to clone mode).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .