1

I upgraded my box from KUbuntu 16.04.3 to 17.10. Everything seemed to be working fine at first but I noticed that my machine had locked up/frozen. The first time it happened my keyboard was not responding and only my mouse was working for a bit before it too stopped responding. So after restarting everything started up normally and I did not see any errors in the logs. So I left it running and again it locked up. I did it a few time and found that the magic time frame is about 4 to 4.5 hours.

I tried to ssh into the box but I was only able to get to server responded to initial ssh request and then just hung and never prompted me for a password. Based on this I figured it was probably a memory leak somewhere. I looked online and I saw a couple of other people reporting freezing due to memory leaks from widgets or other applications, so I ran htop sorted by memory to see if it was a memory leak the cause of my issues but it does not appear to be so. The last thing that htop showed Gridcoin research was the application using the most amount of memory using 2.6% of my memory. Total memory usage was 6.5Gb of Ram and 0Gb of Swap.

The only thing I had running was BOINC, Gridcoin research and Firefox. I turned off my screen saver, I disabled screen locking and I tuned off power saving mode.

After I rebooted my box I checked all the logs and I noticed that they were all still updating up to the point I hit the reset button.

I was wondering if anyone else has had this issue or has seen this issue before and could point me in the direction to check and see what could be the cause of this.

My System Specs. Kubuntu 17.10 64-bit KDE Plasma 5.10.5 KDE Framework 5.38.0 QT: 5.9.1 Kernel: 4.13.0-36 using X11/sddm

Processor: AMD FX 4350/Quad-core Memory: 32Gb Swap: 64gb Video: XFX Radeon R9 285 (Using AMD Drivers)

Things I've done besides updating from 16.04 to 17.10: Updated Repos to ensure I am using the latest version of my installed apps Updated/upgraded all installed apps. Disabled all unused services Uninstalled superfluous applications

UPDATE #1: After noticing that nothing was wrong according to the logs, I left the box run with the same 3 programs and this time it took 6.5hr to lock up. This time however I was able to ssh in to the box (though it took a while) but everything went back to "normal" after I restarted sddm. I did a top and free before I restarted sddm and everything looked normal. Is there a way to tell what could be causing my DM to lock up all response from my box?.

The only thing I did see on my screen was that all BOINC jobs were suspended due to "High CPU usage by User" message. So I guess something ate up a lot of the CPU right before it froze but I don't know what.

UPDATE #2: So I left my box along and dump top to a log. So this time at the 4 hours 18 minus and 51 second mark Plasma jumped from an average 5% CPU usage (0.6% - 21.7%) to 100.4% avg (94% - 105.6%) and Xorg jumped to about the same levels at the same time.

At that exact time syslog shows: watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [plasmashell:15432]

https://paste.ubuntu.com/p/xXqxkpYvhk/

It the repeats the watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [plasmashell:15432] every 23 secs afterwards. This error also appears in the kern.log file.

Hopefully this information helps.

Update #3: So I left the box running for two days without logging on to Plasma. It did not lockup or become unresponsive. I was able to verify that BOINC service was running fine. I then proceeded to log in and changed the KDE wallpaper setting from slideshow to static image. And used it with normal to medium CPU usage for about 2 hours. I then left it idle for about 4 hours. So basically after having an uptime with Plasma of 6 hours (1.5 - 2 hours past its normal lock up point) and it continues to operate normally without any issues.

So I am guessing that the KDE Desktop wallpaper component for 17.10 has some kind of bug that is causing my box to soft lockup.

Anyone know how I could enable debug for just that component?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.