1

I use Ubuntu 17.10 on Dell Latitude 3470 with specs:

CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4
GPU: Intel® HD Graphics 520 (Skylake GT2)
GNOME: 3.26.2
OS type: 64-bit

For my setup I use 2 external Dell 24" monitors, one is connected via HDMI and second is via VGA D-Sub. HDMI is numbered 2 and VGA is 3 in [Settings > Devices > Displays]. HDMI(2) monitor is on the left and VGA(3) is on the right. Every time I startup my laptop monitor sides get reset to VGA on the left and HDMI on the right, and I have to drag the monitor icons in Settings panel to their appropriate sides. I would like to make these setting persistent between boots. What I can do to achieve this?

I tried to run xrandr via ARandr but I got this error:

xrandr returned error code 1: xrandr configure crtc 0 failed

When I run xrandr --verbose the output is:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
XWAYLAND0 connected (normal left inverted right x axis y axis)
    Identifier: 0x21
    Timestamp:  31650222
    Subpixel:   unknown
    Clones:    
    CRTCs:      0
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter: 
  1920x1080 (0x24) 173.000MHz -HSync +VSync +preferred
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.16KHz
        v: height 1080 start 1083 end 1088 total 1120           clock  59.96Hz
XWAYLAND2 connected (normal left inverted right x axis y axis)
    Identifier: 0x289
    Timestamp:  31650222
    Subpixel:   unknown
    Clones:    
    CRTCs:      1
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter: 
  1920x1080 (0x24) 173.000MHz -HSync +VSync +preferred
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.16KHz
        v: height 1080 start 1083 end 1088 total 1120           clock  59.96Hz

Here is content of my /var/log/Xorg.0.log

https://pastebin.com/0zxjNgbf

0

Your output says you have Wayland, not X11, as the display system. I am pretty sure that is why xrandr is not cooperating.

If you change to X11, I have a suggestion. For systems using X11 graphics, I use arandr, a small GUI program that is compatible with all X11 desktops. It allows you to arrange monitors and the save the configuration. Upon reconnect, the setting can be loaded.

Little glitches like this caused Ubuntu to change default from Wayland to X11 in more recent Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.