4

When I find myself in a terminal and want to shut down my computer, I will often use the poweroff command. This has always worked for me on Ubuntu 16.04 64-bit. However, on Ubuntu 17.10 64-bit, I am getting this message:

aaronfranke@ub17vm:~$ poweroff
Operation inhibited by "aaronfranke" (PID 951 "gnome-session-b", user aaronfranke), reason is "user session inhibited".
Please retry operation after closing inhibitors and logging out other users.
Alternatively, ignore inhibitors and users with 'systemctl poweroff -i'.

I know that I can work around the issue using the suggested command, but I want to know, why is this happening? Is there an issue that can be fixed? Should I bother to fix it?

3 Answers 3

4

Similar messages can appear when you type reboot in the command line. The solution is to use sudo reboot instead. In your case it would be sudo poweroff or sudo shutdown which does the same thing. Always make sure you have saved all your work and closed down Libre Office, etc.

The other solution for me is to pick Reboot from the system menu. In this case the sudo isn't necessary. In you case you would pick Shutdown from the system menu.

Lastly, you can do as the message suggests and use:

systemctl poweroff -i
2
  • 5
    This doesn't really explain why the problem happens, but these are good solutions. Oct 31, 2018 at 4:29
  • If you use any of these options described above you can restart/shutdown the computer but the shutdown/reboot process is really slow because it waits for these inhibitors to close for something like 90 seconds each.
    – Bo rislav
    Aug 21, 2019 at 6:41
2

I had the exact same issue in 20.04 . In my case the Caffeine Gnome extension was the inhibitor. I turned it off and now reboot and poweroff work without sudo. Hope this helps.

1
  • this worked in 18.04
    – A.Teator
    Aug 31, 2021 at 1:45
0

You maybe running some program in the background that prevents normal reboot to happen. for example:- if you are running a software in gnome-tweaks that prevents auto suspend and screensaver, you will get that message until you disable that.

Now, in your case i don't know which program preventing it, for a good measure try to see if there is an startup program that you added or a program that you started manually that runs till your shutdown.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.