This question already has an answer here:

I have been booting in to Ubuntu 16.04 from the bios successfully that is until the windows 10 fall creator updates now prevents me doing so. My BIOS mode is UEFI and my Boot options are as follows:

Boot Option Menu
 OS boot Manager
 Ubuntu <TOSHIBA MQ01ABF050>
 ubuntu <TOSHIBA MQ01ABF050>
 Boot From EFI File

Selecting the first Ubuntu in the BIOS shows the following error msg and opens Windows which is not what I want. Selecting the second ubuntu just opens Windows. Please note this error message was only viewable for a second at least and disappeared so I took a video and copied details down.

Malformed binary after Attribute Certificate Table
datasize: ? SumOfBytesHashed ? SecDir->Size:
hashsize: ? SecDir->VirtualAddress : 0x00000068
Failed to loadimage : Invalid Parameter
start_image() returned invalid Parameter

Windows works fine in normal startup.

I have read many posts/answers such as this one https://askubuntu.com/questions/874181/windows-10-update-broke-my-mbr-grub but am really not sure what I should do for my particular system.

This is my system partition after windows updates. system partition

This my UEFI Boot order in BIOS system configuration.

UEFI Boot Order
OS boot Manager
Internal CD/DVD ROM Drive
USB Diskette on Key/USB Hard Disk
! Network Adapter

I tried re-ordering with Secure Boot Disabled but no luck.

I do understand I may have to either reinstall Grub and Ubuntu but some professional advice would be greatly appreciated. Thank you.

marked as duplicate by user535733, Eric Carvalho, karel, David Foerster, waltinator Mar 10 '18 at 16:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


It seems to me that the Linux kernel image got corrupted by the action you mentioned. Simplest way to fix this is to reinstall the kernel by booting into a live Ubuntu (USB). Try replacing vmlinuz and initrd. Make sure you replace the right files by cross checking it with the grub configuration.

  • Ok. Before I go ahead to try this where will I find the vmlinuz and initrd files that you mention to try and replace. – LRBlue Feb 27 '18 at 5:39
  • ...and one more question for now - is it likely I will need to reinstall grub2 or should I do this without question? – LRBlue Feb 27 '18 at 5:41
  • I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Mar 10 '18 at 10:40

Ok I reinstalled ubuntu/kubuntu distro with a live usb, reordered the list in the boot manager and now able to boot from the bios. I had hoped the new installation would detect the previous ubuntu but it did not. Clearly as is mentioned above - the Windows updates have corrupted the ubuntu partition. I have not yet tried replacing the vmlinuz and initrd - will try when I completely understand what I am doing.

Incidentally the windows updates don't all work AND windows can not display the correct time in the southern hemisphere BUT Linux can.

  • 1
    You can ask a separate question about Windows Time vs. Ubuntu Time. – WinEunuuchs2Unix Feb 28 '18 at 23:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.