3

I had run apt upgrade a couple of days back, and restarted my PC a while after, when the top bar and the launcher disappeared. I have tried all the following solutions, but none of them worked:

  1. Reinstall ubuntu-desktop

  2. Removed Unity entirely and reinstalled it again.

  3. Using dconf reset and setsid unity
  4. Enable Ubuntu Unity Plugin
  5. Running unity --reset or initctl restart unity-panel-service just flashes the top bar and the launcher and disappears again.
  6. Removing the compiz-1 folder
  7. Removing the .compiz folder

EDIT:

  1. All upgrades installed + compiz-core is already the newest version(20170630)

I have been searching for solutions for days now without any luck. Although the above solutions have been working for others, none of them seem to work for me. How do I fix this?

Currently running Ubuntu 16.04.3 LTS.

marked as duplicate by David Foerster, Zanna, Eric Carvalho, Volker Siegel, karel Mar 6 '18 at 20:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Please check out the duplicate posted by @N0rbert and let us know if it fixes it or not. – WinEunuuchs2Unix Feb 26 '18 at 18:07
  • The issue persists. On going through related questions, I came across askubuntu.com/questions/1006592/…, where on running apt-get dist-upgrade, the 'The following packages will be REMOVED: ubuntu-desktop unity unity-tweak-tool' warning was triggered. This did NOT happen in my case, if that makes any difference. – Samvid Feb 26 '18 at 18:21
  • 1
    @N0rbert Can you read OP comment above and consider retracting your VTC or asking OP for additional details about duplicate qualification please? – WinEunuuchs2Unix Feb 26 '18 at 18:32
  • What kernel version are you using? uname -r will report it. Can you boot to an earlier kernel version in Grub's Advanced Options menu to see if another version works? – WinEunuuchs2Unix Feb 26 '18 at 18:39
  • uname -r gives 4.4.0-116-generic. I will try booting to an earlier kernel version now, if possible, and see if that fixes anything. EDIT: Booted to 4.4.0-112-generic. The issue persists. – Samvid Feb 26 '18 at 18:44
0

Update: Yesterday I tried advice from WinEunuuchs2Unix answer in ubuntu-menu-and-launcher-not-showing-after-2-16-2018-update and it fixed the problem in my case.

rm -rf ~/.config/compiz-1/compizconfig/* 

I have tried to remove it before, but nothing changed. And just after mesa downgrade, and then removing compiz config files Unity panels come back to their usual places. But I still can't understand what was the main cause of crashing.

  • How did you downgrade mesa? – Samvid Feb 28 '18 at 20:23
  • I download debs from launchpad.net/ubuntu/+source/mesa/17.0.7-0ubuntu0.16.04.2/… and then organized local repo for mesa. And then sudo apt-get update, sudo apt-get install libgbm1=17.0.7-0ubuntu0.16.04.2 ... – edyatl Mar 1 '18 at 8:21
  • I made local repo to prevent broken dependenses, but somebody just used dpkg -i pack_name.deb – edyatl Mar 1 '18 at 8:24
  • Packages: sudo apt-get install libgbm1=17.0.7-0ubuntu0.16.04.2 libgl1-mesa-dri=17.0.7-0ubuntu0.16.04.2 libegl1-mesa=17.0.7-0ubuntu0.16.04.2 libwayland-egl1-mesa=17.0.7-0ubuntu0.16.04.2 libgl1-mesa-dev=17.0.7-0ubuntu0.16.04.2 libgl1-mesa-glx=17.0.7-0ubuntu0.16.04.2 libglapi-mesa=17.0.7-0ubuntu0.16.04.2 mesa-common-dev=17.0.7-0ubuntu0.16.04.2 libosmesa6=17.0.7-0ubuntu0.16.04.2 libgl1-mesa-glx:i386=17.0.7-0ubuntu0.16.04.2 libglapi-mesa:i386=17.0.7-0ubuntu0.16.04.2 libgl1-mesa-dri:i386=17.0.7-0ubuntu0.16.04.2 libgles2-mesa=17.0.7-0ubuntu0.16.04.2 libosmesa6:i386=17.0.7-0ubuntu0.16.04.2 – edyatl Mar 1 '18 at 8:30
  • Just downgraded mesa using the above instructions , and ran rm -rf ~/.config/compiz-1/compizconfig/*. Still no luck. I have also tried downgrading compiz-core-abiversion-20170630 to compiz-core-abiversion-20160415 and removed compiz config files. No luck again. – Samvid Mar 1 '18 at 10:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.