0

I use spanish accents regularly and can't seem to figure out how you use them with Lubuntu.

All of the answers say to just go to keyboard settings, but on my version of Lubuntu, it only has "keyboard and mouse" settings, and the keyboard settings are very limited.

I found in Ibus Preferences I could change the input method where I could select a spanish keyboard, but still don't know how to use accents with it.

I read about dead key methods and altgr dead key methods and tried changing the input to English International settings for each and thought for sure this must be what everyone was describing, but even with the input settings changed, pressing right alt and then the vowel doesn't work. Pressing ' then the vowel doesn't work, pressing right alt then ' then the vowel doesn't work when using these inputs (tried all of these with each dead key input setting).

I have no idea what to try now. I tried looking for the keyboard settings program everyone says to use, but can't find anything new in the software center. I see that Keyboard Layout is apparently already installed, but it doesn't show it anywhere in the preferences, only the "keyboard and mouse" one that doesn't have the same options that I always see in the other posts.

If anyone could help me figure this out, it would be greatly appreciated. Lubuntu works great once I figure out how to do things, but even the simplest of tasks it always seems to take searching around the internet for hours before I can figure it out for the first time. Sometimes I really miss Windows hahaha.

Edit:

System Locale: LANG=en_US.UTF-8

   VC Keymap: n/a

  X11 Layout: us

   X11 Model: pc105

I don't know how you view the keyboard layout for each one, in the screen shot it won't let me do anything.

These are the only options in the "keyboard and mouse" settings

These are screenshots just showing the only options for keyboard I can find. Seems like my version of Lubuntu is pretty limited compared to what answers I read to other posts about this, because I'm unable to find and do the things that they describe.

Last one

Edit: Image to go with one of the comment's suggestion

  • 1
    What's your actual (hardware) keyboard layout? When you selected the Spanish (software) keyboard did you look at the key assignments and try to press the keys that correspond to accented letters? Which characters in particular are you looking to type? Please edit your post, when you want to clarify something or add information. It’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. Thanks. – David Foerster Feb 26 '18 at 19:45
  • This answer might help a bit. – Gunnar Hjalmarsson Feb 26 '18 at 21:54
  • I edited my message to try to include more information that could be relevant. The characters in particular are all the ones with accents in Spanish, which are the vowels, U, and N. I need a way to do it conveniently because I type in Spanish quite a bit, and I've just been not using accents so far (cause I still haven't figured it out), which can change the meaning of words or just make you look illiterate. – Lubuntu Newb Feb 27 '18 at 0:00
1

I figured it out. It was a stupid mistake, but also very easy to overlook.

I kept going to Fcitx Configuration in the preferences. When I would do that, it would look like my screen shot (all boxes empty, unable to change the input method because of this).

By luck today I clicked Fcitx in system tools. Then I went to configuration through the keyboard icon in the bottom right, instead of through preferences. It opened up the same configuration menu as going through the preferences, except with one difference, all the input methods are listed now. Finally I was able to select one with Dead keys, restarted computer, and now it finally works like the way every other post says it should.

I don´t understand why going through preferences to Fcitx configuration shows no options to select, but going through the keyboard icon does, but anyway, that was the problem.

Thanks to all who took the time to comment about this.

0

In the menu look under preferences, Fcitx Configuration, Input method.

Select "English US international with dead keys" and click the right arrow to add it to the keyboard list on the right. Close out of there. Now you will see a keyboard Icon at the bottom right of the main desktop. Use that to select one of the keyboard entries.

Select the keyboard you just added. Here is how to get the characters
type 'a to get á 'e é 'i í 'o ó 'u ú Hold right Alt key and type ? to get ¿ Hold right Alt key and type ! to get ¡ Looks like you can hold down the right alt key and type a to get á and so on.
I can't remember how to get the U with the dots over it.

  • Yeah this is where the confusion came in for me. I can add "English US international with dead keys" in the Ibus preferences, and it will show the keyboard type in the bottom right corner of the screen, that it is apparently selected, but pressing ' with vowels doesn't work. When I go to the Fcitx Configuration, and then input method configuration, everything is blank in all windows and when I click on any of the boxes, no options to select anything appear. I can type in the available input method box, but it doesn't actually do anything if I try to type the keyboard I want to use. – Lubuntu Newb Feb 27 '18 at 15:21
  • Don't go back into Fcitix Config. Instead click on the keyboard icon near the bottom right of the screen. If the keyboard icon isn't there, go to the menu, system tools, Fcitx. That will turn that icon on. From there you can left click on the icon and turn on the international keyboard or select other keyboards. – rkeating Feb 28 '18 at 0:23
  • I edited my main message to include a pic just to confirm that's what you mean. I have it showing it is on, problem is that dead key's don't work when I try what everyone says should work once you change your keyboard. – Lubuntu Newb Feb 28 '18 at 0:37
  • What version are you running? I am testing this on Lubuntu 17.10 on a VM and now anytime I try and change the keyboard the machine locks up. – rkeating Feb 28 '18 at 0:56
  • It says distribution is Ubuntu 16.04.4 LTS, desktop environment is LDXE (Lubuntu) – Lubuntu Newb Feb 28 '18 at 1:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.