2

I'm very new to Ubuntu.

My PC has had very slow boot and shut down times (for 2 days), I reduced the shut down time with this tutorial (https://sites.google.com/site/installationubuntu/home/ubuntu-16-4-lts/make-slow-shutdown-faster) but PC still has some latency problem.

Using systemd-analyze blame from the terminal shows:

17.990s NetworkManager-wait-online.service
 7.379s dev-sda1.device
 5.271s dev-loop0.device
 5.268s dev-loop1.device
 5.264s dev-loop2.device
 4.067s snapd.service
 2.015s postfix@-.service
 1.909s plymouth-quit-wait.service
 1.467s udisks2.service
 1.291s fwupd.service
 1.248s networking.service
  536ms accounts-daemon.service
  447ms tlp.service
  433ms ModemManager.service
  407ms NetworkManager.service
  357ms lm-sensors.service
  349ms keyboard-setup.service
  339ms preload.service
  339ms apparmor.service
  333ms grub-common.service
  333ms mono-xsp4.service
  312ms systemd-logind.service
  304ms apport.service

I think there is a problem but I don't know how to fix it.

  • see askubuntu.com/questions/615006/… on NetworkManager-wait-online.service taking a lot of time. – Rinzwind Feb 26 '18 at 15:14
  • 1
    You do not have any problems. Problems starts with 2-5 minutes bootup. This may occur with many local and network mounts and many servers/daemons. There is no reason to tune system boot-time. It boots once and then you do your work. Do not touch anything systemd-related if it works. If you are newbie, the results of such tuning may result in re-installation. – N0rbert Feb 26 '18 at 15:21
  • @Rinzwind , I read the article and apply some of them, they did work but the actual launch time didn't change. – aysum Feb 26 '18 at 15:46
  • @N0rbert , I understand, I removed the 3rd party apps in list, new results are very good but launch time didn't changed. (oi67.tinypic.com/mhcdcm.jpg) – aysum Feb 26 '18 at 15:52
  • 2
    Note to Close Voters: I don't think this is opinion based because hundreds of other questions about slow boot times are on-topic here. – WinEunuuchs2Unix Feb 26 '18 at 16:57
4

Using one answer within Ubuntu 15.04 network manager causing slow boot worked for me:

systemctl disable NetworkManager-wait-online.service

A bug report for 17.10 has already been filed and you may wish to subscribe to it:

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.