Last night I installed few updates & than run autoremove. Now (when I try to run server for rails projects) its giving me this error

/home/faisal/.rvm/gems/ruby-2.4.2@victory/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:292:in `require': libssl.so.1.0.2: cannot open shared object file: No such file or directory - /home/faisal/.rvm/gems/ruby-2.4.2@victory/gems/puma-3.10.0/lib/puma/puma_http11.so (LoadError)

I tried multiple solutions but didn't work, Can any one help with this.


When I tried apt-cache policy openssl its says

Installed: 1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1
Candidate: 1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1

But on one of my friend's system its version is 1.0.2 has it anything to do with it?

  • Can you show us what you tried ? Or we will probably advice you thinks you already tried – Félicien Feb 26 '18 at 10:02
  • I tried soln like askubuntu.com/questions/339364/… & few other symlink things. Actually I don't have any idea about these things, just trying whatever commands suggested other solutions – Muhammad Faisal Iqbal Feb 26 '18 at 10:06
  • Did you try the exact same command of that answer or did you change the version number of libssl.so to 1.0.2 to conform with the error your getting ? – Félicien Feb 26 '18 at 10:08
  • I tried same one, now when I tried with 1.1.0 it says E: Unable to locate package libssl1.1.0 E: Couldn't find any package by glob 'libssl1.1.0' E: Couldn't find any package by regex 'libssl1.1.0' – Muhammad Faisal Iqbal Feb 26 '18 at 10:11
  • & with 1.0.2 it says ... Package libssl1.0.2 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libssl1.0.2' has no installation candidate – Muhammad Faisal Iqbal Feb 26 '18 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.