1

I have burned OS image (.img) into a new SD card (Sandisk 16GB) use LibreELEC USB-SD creator tool on Ubuntu laptop. I assume I don't need to format SD card before writing. Then I tried browse SD card for files, but Ubuntu not able to show the contents of sd card. It only show space available on SD card. I tried also to browse SD card on Windows PC, but it don't recognized it, when click on SD card drive icon, Windows show alert that SD card first need be formatted. There is also listed volume 537 MB, it can't be opened, when try click to mount it, error message is displayed:

Unable to access "537 MB Volume"

Error mounting /dev/mmcblk0p1 at /media/venitek/3463-3434: Command  line 'mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,shortname=mixed,utf8=1,showexec,flush"
"/dev/mmcblk0p1" "/media/venitek/3463-3434"' exitedd with non-zero exit status 32: mount: /dev/mmcblk0p1: can't read superblock

Edit: here is output fdisk -l command:

$ sudo fdisk -l
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xb45e11b8

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048    718847    716800   350M de Dell Utility
/dev/sda2          718848   7010303   6291456     3G  c W95 FAT32 (LBA)
/dev/sda3  *      7010304 960389119 953378816 454.6G 83 Linux
/dev/sda4       960391166 976771071  16379906   7.8G  5 Extended
/dev/sda5       960391168 976771071  16379904   7.8G 82 Linux swap / Solaris

Partition 4 does not start on physical sector boundary.


Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xbe03dce7

Device         Boot   Start     End Sectors  Size Id Type
/dev/mmcblk0p1 *       8192 1056767 1048576  512M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      1056768 1122303   65536   32M 83 Linux

I tried also commmand dd if=/dev/sdb1 bs=1024k count=10 | less, it show just vertical list of tilde ~ chars, not sure if it's readable.

  • For some devices SD card is just one block device without partition table. You can try to investigate its contents with binwalk. But simple way is to insert it to Raspberry Pi and boot system from it. You are using RPi, right? – N0rbert Feb 26 '18 at 9:45
  • No, I am not using Raspberry. I need replace one file on SD card, but first I should locate this file on sd card. – triwo Feb 26 '18 at 10:04
  • Understood. So it should contain files. To check that card is working you may try to format it from gnome-disks. Also you can create, mount and unmount partitions from GNOME Disks. – N0rbert Feb 26 '18 at 10:10
  • Then if would be better to format sd card with dedicated SD Memory Card Formatter tool. Do I really need to format sd card before writing image? – triwo Feb 26 '18 at 12:59
  • I do know the state of your SD card. It may be faulty. But for testing you may create empty partition table on it with GNOME Disks or gparted and add partition to it. If this partition mounts and you can store files on it, then SD is operating normally. And problem is in USB-SD writer or how you use it. – N0rbert Feb 26 '18 at 13:21
0

The ability to write .img or .iso files is built into Ubuntu, don't use some weird third party tools. Either just double-click on the .img file in Nautilus (the file browser), or right-click on it and then select to pass it to the image writer. Select your SD card as target and choose to "recover" the image.

If your Windows can read the resulting USB or not depends on the file system that is written to the card.

-1

Please follow the below steps and it should fix this for you.

  1. Remove any SD card that are inserted into the SD card reader.

  2. Launch the terminal.

  3. Run the following command to reinstall udisks2.

    sudo apt-get install --reinstall udisks2
    

    You will have to enter root password to complete reinstallation.

  4. After the installation is complete, close the terminal and reboot the PC.

  5. Try inserting a SD card into the SD card reader slot. It should work now.

  • 1
    Just to clarify my issue: SD card is detected/recognized in Ubuntu, but I can't view/browse files. – triwo Feb 26 '18 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.