I'm using Ubuntu 16.04 inside VMWare Fusion application on Mac OS X.

In VMWare Fusion app, Hard Disk space is set to 30GB and when I run fdisk -l command, I can see 30 GB being recognised for Ubuntu.

sudo fdisk -l
Disk /dev/sda: 30 GiB, 32212254720 bytes, 62914560 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x428e85f3

Device     Boot    Start      End  Sectors  Size Id Type
/dev/sda1  *        2048 39845887 39843840   19G 83 Linux
/dev/sda2       39847934 41940991  2093058 1022M  5 Extended
/dev/sda3       41940992 62914559 20973568   10G 83 Linux
/dev/sda5       39847936 41940991  2093056 1022M 82 Linux swap / Solaris

Partition table entries are not in disk order.

Below is the link for output from gparted application,

enter image description here

Below is the link for output from Disk Usage Analyzer application,

enter image description here

I would like to understand why newly added 10 GB is not part of DUA. Is the newly added 10 GB not considered for system usage?

I followed below post for adding disk space,

How do I add an additional hard drive?

Only thing I tried different was mount procedure.

The output of file /etc/fstab is as below,

cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=c68dd12e-7f25-4a1d-be68-a136a19ea87d /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=fba4ca03-2aa4-42f6-b5ff-da669ea3579b none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/swapfile none swap sw 0 0
/dev/sda3    /    ext4    defaults    0    0
  1. It seems that you have added the added space as a new partition, sda3.
  2. In /etc/fstab you are trying to mount sda3 as /, but you have already mounted sda1 on / earlier in fstab.

From your question it is not clear to me how you wanted to use your new disk space. But either you will have to mount sda3 on a valid mountpoint (an empty directory) or expand your existing / (root) file system. In the case you will have to:

  • Boot your system on a live media.
  • Start gparted
  • Delete sda3
  • Move the swap partition to the right into the free space
  • Expand sda1 to the right
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.