4

When I boot Ubuntu or Fedora, they show a black screen with a bunch of [OK] messages for startup processes.

It seems like an old style DOS system. Nowadays, iOS and Windows don't show those terminal-like results. Elementary OS doesn't show it (most of the time) either.

Can I hide them in Ubuntu?

The answer to this question doesn't work in my case because my /etc/default/grub already has GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" but it still shows the boot text.

Output of apt-cache policy plymouth | grep Installed:

Installed: 0.9.2-3ubuntu17

Here's my /etc/default/grub

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
GRUB_CMDLINE_LINUX=""

Update 7 Mar 18:

After running:

sudo apt-get clean, apt-get autoremove, apt-get update, apt-get upgrade

The result is the same: First Ubuntu boots with the logo and 5 loading dots Then, the screen show these: (a lot of them)

...
[ OK ] Started CUPS Scheduler.
<more yidi yada>
[ OK ] Started Run anacron jobs.
[ OK ] Started ACPI event daemon.
[ OK ] Started Set the CPU Frequency Scaling governor.
       Starting Hold until boot process finishes up... any system changes.pp link was shut down.

Then Ubuntu shows login screen with username.

Also:

$ sudo dpkg-reconfigure -a
[sudo] password for user: 
Unknown option: a
Usage: dpkg-reconfigure [options] packages
  -u,  --unseen-only        Show only not yet seen questions.
       --default-priority   Use default priority instead of low.
       --force          Force reconfiguration of broken packages.
       --no-reload      Do not reload templates. (Use with caution.)
  -f, --frontend        Specify debconf frontend to use.
  -p, --priority        Specify minimum priority question to show.
        --terse         Enable terse mode.

$ sudo dpkg-reconfigure plymouth
[sudo] password for user: 
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Processing triggers for initramfs-tools (0.125ubuntu12) ...
update-initramfs: Generating /boot/initrd.img-4.13.0-36-generic
  • $ apt-cache policy plymouth | grep Installed Installed: 0.9.2-3ubuntu17 – Viet Feb 25 '18 at 17:04
  • You can set GRUB_CMDLINE_LINUX_DEFAULT=quiet (and then sudo update-grub) as suggested in the accepted answer to the duplicate question. – pomsky Feb 26 '18 at 8:14
  • Thank you @pomsky, unfortunately, that also didn't work. After editing the grub and updating it. Instead of showing the Ubuntu logo then a bunch of [OK] boot text, now it shows a bunch of [IBUS] boot text, no logo, then the login screen. – Viet Feb 26 '18 at 13:37
  • With Ubuntu 18.10 there are many [OK] messages even after logging in. Very annoying, so unprofessional. – Peter Quiring Dec 10 '18 at 14:19
2

short answer: yes! :) you can customize Ubuntu or Fedora whatever way you like. I don't know what version you are running, but under any normal installation i believe plymouth should be installed.

Plymouth is the application which provides the graphical "splash" screen when booting and shutting down an Ubuntu system.

There is an entire Wiki on this topic on the ubuntu website here: https://wiki.ubuntu.com/Plymouth I think the reason yours is not working is because either the kernel is not set up to use plymouth correctly, or your grub bootloader was set up to boot the os in text-mode.

Another issue i've encountered before myself, is that my Ubuntu wasn't shut down properly, which causes it to boot in a system check, and that also shows the terminal output.

  • and by the way, do you know how to hide the boot text? i have GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" but the boot text is still there every time. – Viet Feb 25 '18 at 17:00
  • where exactly did you put that parameter? i believe this has been answerred here: superuser.com/questions/44280/hiding-the-boot-up-text-in-ubuntu – Glenn van Acker Feb 25 '18 at 17:05
  • Hi @Glenn van Acker. Thank you for the suggestion. However, in my case: $ sudo nano /boot/grub/menu.lst shows an empty file. – Viet Feb 26 '18 at 13:32
  • that is very strange, can you try running a grub-update? – Glenn van Acker Feb 26 '18 at 14:43
  • yeah. i have run grub-update. after that, I undo all those changes and ran grub-update again, now it's back to square one. – Viet Feb 27 '18 at 14:38
1

Those fancy OK/FAIL messages that you see are actually boot messages that are output to TTY1 during the boot process.

To answer your question, that technically is not a shell, but a separate program, namely the systemd init system that puts out those messages.

You can hide those messages but i need to look it up. Since i never hide it, i like it actually.

Edit :

To hide those messages edit the /etc/default/grub

sudo nano /etc/default/grub

Change these lines :

GRUB_CMDLINE_LINUX_DEFAULT=quiet   #Don't show Ubuntu bootup text
GRUB_CMDLINE_LINUX="console=tty12" #Don't show kernel text

Update grub :

sudo update-grub

Instead of hiding use a splash screen to cover it up.

Using plymouth, a graphical startup animator, you can provide a pretty bootscreen that is well suited to desktop machines.

sudo apt-get install plymouth-theme-ubuntu-logo

You will find a how-to on this link : Boot your Linux silently

  • They don't work. The only thing that is changed is the logo, now it's the name of the version of my Ubuntu. All the boot text is still there. – Viet Feb 26 '18 at 13:29
  • Have you followed that link ? Also change the line that outputs to another tty as i did in my answer. – An0n Feb 26 '18 at 14:04
  • I have, but it doesn't make much sense to me. It doesn't say which file I need to edit those values. – Viet Feb 27 '18 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.