0

i run this script fine from terminal, from a .sh file:

xdotool search --class chromium set_desktop_for_window %@ 4 &
wmctrl -r \"chromium\-browser\" -t 4 &
#sleep2
xdotool search --class gnote set_desktop_for_window %@ 0 &
wmctrl -r "gnote" -t 0 &
#sleep2
xdotool search --class caja set_desktop_for_window %@ 1 &
wmctrl -r "caja" -t 1 &
#sleep2
xdotool search --class conky set_desktop_for_window %@ 8 &
wmctrl -r "conky" -t 8 &
#sleep2
xdotool search --class psensor set_desktop_for_window %@ 8 &
wmctrl -r "psensor" -t 8 &
#sleep2
xdotool search --class mate-volume-control set_desktop_for_window %@ 8 &
wmctrl -r "mate-volume-control" -t 8 &
#sleep2

but when i run it from a startup script file (from a command line like “bash ~/.movetoworkspaces.sh”), or having it opening another terminal window (like “mate-terminal -e "bash ~/.movetoworkspaces.sh"”), it simply doesn‘t work

the startup script works fine on running all those applications, but both xdotool and wmctrl simply doesn’t work there, neither from the startup script, or from another script

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.