1

On my LAN I have a host named pleurotus. I can ping pleurotus.local but not pleurotus-- the host isn't found. Is there a way to make .local implicit, perhaps by putting some magical entry in the hosts file?

0

Add search local to the file /etc/resolv.conf.

  • cat /etc/resolv.conf on modern systems returns # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN. Are you sure? – N0rbert Feb 25 '18 at 11:05
  • Apparently I need to use the resolvconf command with the -a option. But resolvconf -a search local just sits there. – Paul A. Feb 25 '18 at 15:39
  • I've tried "resolvconf -a search.local" and "resolvconf -a search local" but neither command did anything. – Paul A. Feb 27 '18 at 18:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.