0

With the new windows update killing support for SMB 1, I'm attempting to force my ubuntu (desktop version) server to use SMB 2 or 3. I've been around and it says to change the min protocol and max protocol settings in the smb.conf, but those options don't seem to exist. any ideas? I'm using Ubuntu Desktop 16.04 LTS.

1

The exact settings are:

  • client min protocol
  • client max protocol

Then you should configure your /etc/samba/smb.conf with the following commands on [GLOBAL] section

[GLOBAL]
client min protocol = SMB2
client max protocol = SMB3

after that you should restart smb service as root:

# systemctl restart smb
# systemctl restart nmd

man smb.conf for more details

  • how do I access the [GLOBAL] section from the command line? – Daniel Feb 25 '18 at 4:35
  • --option=<name>=<value> man smbd for details. Anyway to configure smb.conf you must edit the file with vim or nano The [GLOBAL] sectin is at the beginning of the file. – MysticDog Feb 25 '18 at 15:47
  • The issue I'm having is even open in vim, the client min/max protocol settings simply aren't there. At the top of the page, it says "Samba has a huge number of configurable options most of which are not shown in this example." – Daniel Feb 26 '18 at 0:48
  • the lines that begin with # are comments. If the "client min protocol" is not there you have to add it. As I said you have to open /etc/samba/smb.conf with vim and go under [GLOBAL] section and there add the client min/max protocol configuration. Then restart the service. – MysticDog Feb 26 '18 at 17:21
  • Okay, I've added the commands. with smbstatus, it shows my username and says SMB3_02 under protocol version. I am still unable to access the server from my windows PC. I'm assuming at this point, it's no longer an Ubuntu issue, correct? – Daniel Feb 26 '18 at 19:30
0

If you are mounting your shares through fstab on the client, then include vers=3.0 as an option after cifs and that will set up a SMB 3.0 connection.

When I tried to up the min protocols on the server, many of my clients could not connect. I had better luck setting the version number on the client side. (I am still learning this myself.)

0

2 different min/max protocols.

When a client machine to your Ubuntu server accesses your machine it will negotiate which smb dialect to use between two settings on the server: server min protocol and server max protocol. By default those settings are lanman1 and SMB3. If your client machine does not want to access your machine using smb1 it can go all the way up to SMB3 without changing anything on the server.

client min / max protocol is for Ubuntu connecting to another server and changing it did nothing relative to this question.

Something else appears to be a problem with your one client.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.