1

I am running Kubuntu 14.04 on a 32-bit system and I'm trying to install ddccontrol so I can change my monitor brightness without touching the monitor in a GUI. I understand I need to install the CLI version first to get the GUI version (gddccontrol) as is my goal. I have found multiple packages on GitHub and Launchpad and have tried all that I can find. Most of the .deb packages I’ve ran with package installer have an error of Cannot satisfy dependencies. When I try the instructions on GitHub along with other suggestions like sudo apt-get or apt install, I get the error "E: unable to locate package" and then the name of the package I'm trying to install. Recently I got an error of no installation candidate.

0

I think that we can get sources of ddccontrol package from Xenial and build it on Trusty.

Usually this method is not recommended, but I do not imagine other effective method.

We will build deb-packages with debuild.

Execute the following commands:

# update package lists and install all needed build dependencies
sudo apt-get update
sudo apt-get install -y build-essential dpkg-dev libxml2-dev \
libpci-dev libgtk2.0-dev devscripts autotools-dev \
intltool xsltproc tidy gksu libgksu2-0 libgtop2-7 libgtop2-common

# add universe source from xenial
echo "deb-src http://archive.ubuntu.com/ubuntu/ xenial universe" | \
sudo tee /etc/apt/sources.list.d/xenial.list

sudo apt-get update

# create directory and get source package of ddccontrol from xenial
mkdir ddccontrol-xenial
cd ddccontrol-xenial

apt-get source ddccontrol

# go to ddccontrol-0.4.2 directory, compile and build deb-packages
cd ddccontrol-0.4.2
debuild -i -us -uc -b

# get ddccontrol-db from xenial and install it manually
wget http://mirrors.kernel.org/ubuntu/pool/universe/d/ddccontrol-db/ddccontrol-db_20061014-4_all.deb
sudo dpkg -i ddccontrol-db_20061014-4_all.deb

# install all
sudo dpkg -i ../*ddc*.deb

# remove universe source from xenial
sudo rm /etc/apt/sources.list.d/xenial.list
sudo apt-get update

I found real machine with Ubuntu 14.04 LTS.

It is needed to load i2c-dev kernel module:

 sudo modprobe i2c-dev

Then launch sudo ddccontrol -p from terminal or gddccontrol from menu.

6
  • This installs ddccontrol, but when I go to gddccontrol there is an error: No monitor supporting DDC/CI available. If your graphics card need it, please check all the required kernel modules are loaded (i2c-dev, and your framebuffer driver). I know the monitor I'm using worked with ClickMonitorDDC in windows. – Josh Allison Feb 27 '18 at 1:58
  • I think that main part of question is solved - we got ddccontrol installing on trusty. I tested this method on VirtualBox, so it uses 'virtual monitor'. I have never used DDC in modern Ubuntus. You can try to launch it from Xenial LiveCD/USB and compare results. Also you can try to check i2c availability with sudo get-edid | parse-edid (both commands are available from read-edid package). – N0rbert Feb 27 '18 at 20:21
  • 1
    I'm not sure what the output means. It says DDC1 not supported in transfers but DDC2 is. EDID is successful as well as VBE interface. At the end it says "Looks like VBE was susccessful." – Josh Allison Feb 27 '18 at 23:29
  • Just tested on real 14.04 LTS - sudo modprobe i2c-dev is needed before launching ddccontrol. – N0rbert Feb 28 '18 at 7:51
  • I tried this on two computers (one kubuntu and another ddc program in windows 7) with three different montiors. Two work with the windows program but not with this setup. I know they should work because the third monitor does not support DDC. After loading i2c-dev I am now getting the error "The current monitor is in the database but does not support DDCC/CI." along with something about trying a different port on the monitor. One of the monitors has a DVI and VGA and the other only has one VGA. I don't know if ddccontroll would work on the DVI because I can't connect it to my PC. Any ideas? – Josh Allison Mar 1 '18 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.