0

I am using Ubuntu 16.04.3 LTS 64 bit. When I press the 'Suspend' button, it goes to suspend but immediately resumes again without me pressing any other device. And what's worse is that when it resumes, the monitor remains in sleep and pressing keyboard buttons does not seem to have any effect and the only way I seem to be able to start working is by pressing the physical restart button on the system box (which of course forcefully restarts the PC). How do I fix this?

  • Where is the Suspend button on your PC case or your keyboard? What are the make and model? Have you tried to suspend via the menu? Any difference? – WinEunuuchs2Unix Feb 24 '18 at 22:36
  • @WinEunuuchs2Unix I tried suspending via the menu. I am using a Desktop and I cannot see a hardware suspend button neither on the PC case nor the keyboard. – CluelessNoob Mar 17 '18 at 16:43
  • You meant a "software button on the screen" I read it as a "hardware button". My mistake... – WinEunuuchs2Unix Mar 17 '18 at 16:44
0

Suspend does not turn off your computer.It puts the computer and all peripherals on a low power consumption mode.Hibernate saves the state of your computer to the hard disk and completely powers off. When resuming, the saved state is restored to RAM. For suspending you can just close your Lid ,that way it wont restart !

you can also try this Go to /etc/defaults/grub, change value of GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs"

Then run: sudo update-grub

  • I am using a Desktop, so there is no lid. What does GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs" actually do? Can you please explain before I actually try that? – CluelessNoob Feb 24 '18 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.