2

I have a Dell XPS 13 Dev edition with 16.04. Today my touchpad stopped working, I think it was right after I unplugged an external screen. Nothing happens if i press or touch the touchpad, the pointer just won't move.

  • If I connect an external mouse I am able to use it to move the pointer without problems.

  • I know the hardware is not broken because if I boot into Ubuntu 16.04 from a USB stick the touchpad works.

Running

synclient touchpadoff=0

Did not help. Neither did

sudo modprobe i2c_hid

Or adding

grub_cmdline_linux_default= quiet splash acpi=force

to /etc/default/grub.

If i run

less /proc/bus/input/devices

I see my touchpad, and it is also visible in xinput as

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎜   ↳ Logitech USB Laser Mouse                  id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]

Anyone know what to do?

  • Actually just noticed something else, the speakers area also completely dead. If I go into sound settings I only have: play sound through: dummy output. And it also doesn't work if I plug in a pair of headphones. Any help would be greatly appreciated! – Carl Feb 24 '18 at 17:54
  • I'm finding the same thing with my laptop :( – Matt Gaunt Jan 8 '19 at 18:52
  • Try to update bios, that fixed it for me – Carl Jan 9 '19 at 19:43
0

I managed to get my trackpad working by using libinout instead if synaptics.

Wrote up what I tried here: Dell XPS 13 9350 - Trackpad tap works but trackpad click does not

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.