1

I need to change the language from keyboard for example : Alt+Shift or similar.

I have already installed all language.

Switching keyboard language by Right Alt+Shift does not work. Alt+Shift doesn't change language. I can't type my language even with ru, bg, en input switched on in language bar.

The language is bar missing.

Edit from comments:

I have UK and Bulgarian keyboards enabled, I have enabled Alt+Shift as the primary short cut and Ctrl+Alt+K as the alternate in my settings. the current selected keyboard layout is not indicated in the systray and I cannot find a plasmoid for it either. If I hit Alt+Shift nothing happens. If I hit Ctrl+At+K a rounded grey square with icon of a globe and letters UK (representing UK layout) are displayed on screen, if I hit the combination again, it again shows uk and does not switch the layout.

  • ? Super ? what's that Super key ???? – Stoyan Todorov Feb 23 '18 at 20:36
  • Super+Space not working .All key combinations for changes language not working. How to Make set shortcuts to change keyboard layout? THANKS. – Stoyan Todorov Feb 23 '18 at 20:43
  • i know that from the beginning when i install first day kubuntu 17.10. i have all actualization. i set restore points . also the same problem. – Stoyan Todorov Feb 23 '18 at 21:04
  • I have UK and Bulgarian keyboards enabled, I have enabled Alt+Shift as primary short cut and Ctrl+Alt+K as alternative in my setting. Current selected keyboard layout is not indicated in the systray and i can not find a plasmoid for it either. If I hit Alt+Shift nothing happens. If I hit Ctrl+At+K a rounded grey square with icon of a globe and letters UK (representing UK layout) are displayed on screen, if I hit the combination again, it again shows uk and does not switch the layout. – Stoyan Todorov Feb 24 '18 at 12:09
  • Yes i have installed the Bulgarian language support in addition to the keyboard layout. But i can't type in different language, only English . All menu design it's on Bulgarian language. – Stoyan Todorov Feb 28 '18 at 1:33
0

I don't know of you are talking of ubuntu desktop or server but this is how I walked passed both situations with Ubuntu 17.10.

For ubuntu desktop, --> settings --> region and language after selecting your languages, make sure u click on manage installed language to make sure they are available for support. I combine "windows logo" key + "space" key to switch between langauges. enter image description here.

And for ubuntu server, you can use this command here (a similar response to your question). Following @steeldriver 's cmd aproach, it worked for me, so I guess you will find something like pc / qwerty / Bulgarian / standard / standard amongst other layouts in your language(s). Hope it helps.

  • Here's an inline link to Google Photos. – Stoyan Todorov Mar 18 '18 at 8:35
  • There is a solution to the problem. I reinstalled Kubuntu. I installed the Bulgarian language and everything worked. – Stoyan Todorov Apr 6 '18 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.