8

I am trying to upgrade to 18.04 using sudo do-release-upgrade -d, but it exits the installation with the message:

Calculating the changes

EFI System Partition (ESP) not usable 

Your EFI System Partition (ESP) is not mounted at /boot/efi. 
Please ensure that it is properly configured and try again. 

Restoring original system state

Aborting

I have Windows on this machine as dual boot. Fast boot is disabled on Windows 10.

I have tried to mount it in GParted but the option is disabled...

/dev/sda1 info which is ESP

What should I do to be able to move forward?

  • You could start by verifying that you have a /boot/efi filesystem mounted. – Soren A Feb 23 '18 at 8:31
  • it is not mounted 'I have tried to mount it in GParted but the option is disabled...' – M U Feb 23 '18 at 8:32
13

You have to mount your ESP. This should work with:

sudo mount /boot/efi 

If you get an error message like

mount: can't find /boot/efi in /etc/fstab

you have to add a line to your /etc/fstab e.g.

UUID=XXXX-XXXX  /boot/efi       vfat    umask=0077      0       1

replace the XXXX-XXXX with the UID of your ESP (e.g. from the output of blkid /dev/sdxX or from gparted (92E8-1BEE in your case))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.