0

I'm having an issue with Google Chrome, more specifically with touch scrolling (drag and drop style) on few MSI All -in - One computers.

I'm using three models of these kind of computers - the joke is it's actually working on two types of them (MSI Pro 16B Flex, AP1622ET-226XEU) but it doesn't work at AP1622ET-037XEU.

It's doesn't make sense, because I've already updated the touch driver to the newest one - they use same eGalaxTouch pointing input device, also they're both working working on same version of system, same version of Chrome (newest in repo). Chrome://flags options are set to same values. I've already tried with --touch-devices start option.

I've already searched forum for walkaround for this issue, but none of them solved my problem.

If anybody could help - I'd be grateful.

Regards.

0

Solution:

First of all,

sudo nano /etc/modules

Paste

usbtouchscreen

usbhid

Right after lp, then load modules (only at 1st time) by command

sudo modprobe usbtouchscreen usbhid

Right after that, you have to download and extract eGalax Touch driver (you have to choose compatibile driver with your kernel version; check it by:

uname -r

Open terminal in folder you extracted the driver, then

sudo sh setup.sh

After that you get prompted you have to reboot, so: reboot or systemctl reboot -i

Next step to do is to edit SystemD service:

sudo systemctl edit --full eGTouch.service

Overwrite the code with this one below:

 # eGalax Touchscreen service file

[Unit]
Documentation=man:systemd-sysv-generator(8)
SourcePath=/usr/bin/eGTouchD
DefaultDependencies=no
Before=sysinit.target
After=apparmor.service

[Service]
Type=forking
Restart=always
RestartSec=5
StartLimitInterval=60s
StartLimitBurst=3
TimeoutSec=0
IgnoreSIGPIPE=no
KillMode=process
GuessMainPID=no
RemainAfterExit=no
User=root
Group=root
ExecStart=
ExecStart=/usr/bin/eGTouchD start
ExecReload=/usr/bin/eGTouchD restart
ExecStop=/usr/bin/eGTouchD stop

[Install]
WantedBy=multi-user.target

Remove the SystemV.init script:

sudo rm /etc/init.d/eGTouch.sh

Then enable the SystemD service you just created:

sudo systemctl enable eGTouch.service
sudo systemctl daemon-reload

And at the end, restart it.

sudo systemctl restart eGTouch.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.