4

Since the update to 17.10 gnome shell is included in ubuntu what i love. Before the update i always ran a gnome shell on top of it.

But on the gnome shell of 17.10 i noticed that the gnome shell uses alot of CPU. Not always but in spikes.

See image

Is there a solution to this?

  • Are you in Wayland? If so, what happens if you switch to Xorg? – pomsky Feb 22 '18 at 16:39
  • @pomsky if wayland is the default launcher of ubuntu in 17.10 yes i am. and i havn't tested that yet – Cyber_Star Feb 22 '18 at 16:42
  • @pomsky Still the same – Cyber_Star Feb 22 '18 at 16:49
3

More than likely it's an GNOME Shell extension that you've installed.

Go to https://extensions.gnome.org/local/ and disable any new/recent extensions that you may have installed, and then log out, and then log back in. See if the problem is gone. If it is, go back and re-enable one extension at a time to narrow down which one caused your problem.

  • Disabled them all and seems to work. Should have tought about this. thanks – Cyber_Star Feb 22 '18 at 22:11
0

I noticed this as well, the CPU would never go less than 20% and would often shoot over 50% while just moving the mouse, and also the mouse cursor wasn't moving smoothly.

I was using Wayland and I just gave X11 a try and I noticed that it works fine on X.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.