-1

I just installed 16.04 LTS on my new desktop, Dell Alienware Aurora R7, with i7-8700K, 32GB RAM, SSD(SM961 NVMe SSD) and 1080TI.

So far, everything works ok except I get a kernel panic when I try to shutdown (reboot works ok).

kernel panic screen capture

How can I avoid that?

0

I was actually looking into this due to the fact that I might get the same system.

There was a previous question for this situation for which an answer mentioned choosing a previous kernel version. That might solve it: Ubuntu 16.04 LTS IRQ kernel panic at shutdown - Alienware R7 desktop

BTW did you try the system with the latest non-LTS version of Ubuntu? That could also work.

  • Thanks for your answer. I tried but it doesn't work. – John B. Kim Feb 23 '18 at 13:49
0

I have an Alienware Aurora R7/0VDT73, BIOS 1.0.11. The system crashed on shutdown because of IRQ issues on a built-in-module (i2c-designware-core).

I solved this by editing the file /etc/default/grub and adding the kernel option noapic, to this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet noapic splash"

After that you should also launch the command:

sudo update-grub

Now my system shuts down without any problem.

0

How I solved this issue!

Add initcall_blacklist=dw_i2c_init_driver to the kernel command line. This works for me on kernel 4.15.0+.

For anyone else who'll find this answer. You can do it by editing /etc/default/grub:

Run in the terminal: sudo -H gedit /etc/default/grub.

(if you don't have gedit installed use your favorite text editor or "sudo apt install gedit" without quotes)

Append blacklist string to the GRUB_CMDLINE_LINUX_DEFAULT: GRUB_CMDLINE_LINUX_DEFAULT="quiet initcall_blacklist=dw_i2c_init_driver".

Save the file, close the editor.

Run in the terminal: sudo update-grub.

Reboot and test!

Credit goes to this post: https://unix.stackexchange.com/questions/423797/how-do-i-disable-i2c-designware-support-when-its-not-built-as-a-module/446913#446913

These are my specs for this rig. Alienware Aurora R5 Nvidia GTX 1070/8GBvram 8GB ram i7 Intel core processor(8core)"Skylake"

  • It seems that this is the actual answer " How I solved this issue was installing Manjaro and using their built in kernel installer,and switched to a "Real Time" kernel. " I suggest editing your answer to make this stand out more. – Organic Marble Jun 27 '18 at 1:32
0

On my Dell Alienware 17R3 with Samsung Pro 960 NVMe SSD I had a problem suspending/resuming lockup fixed by editing /etc/default/grub and adding the parameter acpiphp.disable=1 to the line containing:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Afterwards it looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpiphp.disable=1"

Save the file. Next update /boot/grub.cfg and generate a new initrd.img with the command:

sudo update-grub

Finally reboot and test.


I don't have the PM961, but rather the 960 Pro so haven't experienced your issue. If none of the other answers or comments help one last thing you could try is:

nvme_core.default_ps_max_latency_us=5500

parameter in /etc/default/grub LINUX kernel argument list. I just found this in Arch Linux. There are other steps you may wish to investigate in the link.

protected by WinEunuuchs2Unix Jun 27 '18 at 2:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.