3

After auto-update from kernel 4.4.0-112-generic to 4.4.0.116-generic, the Broadcom wlan adapter is no longer available. As I did not yet have time for further research, I removed the 4.4.0-116 kernel package and switched back to 4.4.0-112 to keep the laptop functional.

With kernel 4.4.0-112, it appears that the wlan-adapter uses the module wl.

I can't find any info on this issue in the 4.4.0-116 package's release notes.

Do I need to update the wl-module manually? Do I need another module?

Any help appreciated! And happy to provide more info if anyone point me to the right places to find it.

  • I had the same problem with my linux mint laptop today after upgrading from 4.4.0-112. I was unable to find any other solution so i just rolled back to my previous kernel. – theVoid Feb 23 '18 at 16:16
  • In the 4.4.0-116 kernel, try sudo apt-get install --reinstall bcmwl-kernel-source There is an issue with gcc and compiling right now bugs.launchpad.net/ubuntu/+source/xorg/+bug/1750937 – Jeremy31 Feb 24 '18 at 21:08
  • @Jeremy31 I tried that, but it didnt work. It just disabled my wifi even when i boot with the 4.4.0-112 kernel. In case you have the same problem I fixed it by just switching a driver my driver with an other + reboot and then switch back to my original driver + reboot from the driver manager. I hope they fix it or else I will stay with the 4.4.0-112 kernel forever. – theVoid Feb 28 '18 at 20:46
  • 1
    @theVoid you may also need the gcc-5 update otherwise the vermagic for the wl module isn't correct for the 4.4.0-116 kernel – Jeremy31 Feb 28 '18 at 21:50
  • @Jeremy31 yup that did fix the problem, thanks a lot! – theVoid Mar 2 '18 at 5:35
0

I had the same problem, resolved by updating to the latest version of bcmwl-kernel-source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.