6

When I typed the title I was directed to another question "Hindi display of words such as "pra" "gra"". My experience is somewhat different than discussed there. The display is correct in LibreOffice and Text Editor but not in browser search results page. Again if you click the link with incorrect display the actual website displays correctly. I experimented with copying the incorrectly displayed lines and pasted in text editor and it displayed correctly.
as shown in this image

This problem seems to be only in Debian/Ubuntu and distros based on them. I have tried a few other distros like Fedora, Manjaro and Solus and everything is displayed correctly in them.

5

2 Answers 2

7

This is an issue with the default fonts used by the browsers

See How do I enable writing in Indian languages? if you have not enabled Indian language yet. This answer is for problems specific to Indian language font rendering in the browser.

For some reason Indian fonts are not rendered correctly in the browsers in Ubuntu. Changing the default fonts used by the browsers solves it. The instructions below are for Chrome. The same can be done for Firefox.

Steps:

First: Open the Chrome settings and scroll down to Appearance.

Second: Click on Customize fonts

enter image description here

Third: Change the Standard Font to a font that fully supports Indian languages. Here I have chosen Lohit Devanagari but you can choose another one.

enter image description here

The proof of the pudding...

enter image description here

is in eating!

Hope this helps

3
  • Thanks. This has solved the issue for me. I have to do this for every browser. But I expect this to work out of box which is true for Windows, Mac, iOC, Android, Fedora, Manjaro, Solus, Slacko Pup etc for all browsers. Why can't Ubuntu do this? How do we tell and request Ubuntu team to look into this? Regards. Feb 23, 2018 at 4:28
  • You have to file a bug report to the Ubuntu developer team. See help.ubuntu.com/community/ReportingBugs for how to do that. Bug reports are off-topic here in this site.
    – user68186
    Feb 23, 2018 at 16:04
  • this is also a problem on arch Jan 3, 2019 at 8:52
0

This is happening because of fonts.

To render any language text, font should support that text. Default fonts of Ubuntu does not render Devanagari correctly.

In order to correctly show devanagari text, we need a font which is fully supporting devanagari.

To setup the correct font we need to do following steps.

  1. Download Noto Sans Devanagari. This package contains many fonts.
  2. Open Home folder and check for hidden files. You can use Ctrl + H for the same.
  3. If you cannot find .font folder, create one. Extract downloaded zip file into this folder. This step will integrate all these fonts into Ubuntu. So technically you can use any of these fonts in any of the software.
  4. Open settings of chrome. Search for font. Click on Customize Fonts.
  5. Change Standard Font to Lohit Devanagari or any other font which renders devanagari correctly.

To render devanagari correctly in any other application, we can do the same by selecting font as Lohit Devanagari.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.