3

I have a desktop and laptop both running ubuntu 16.04. My android phone is configured as 'MTP' mode when connecting. When connecting the phone to my laptop, ubuntu displays a nice icon on unity launch bar and an entry within nautilus -- it's a happy day scenario.

However, when connecting that android phone to my desktop, nothing happens.

here is some facts when connecting to desktop

> lsusb 
Bus 001 Device 005: ID 12d1:1052 Huawei Technologies Co., Ltd. 

> mtp-detect   
libmtp version: 1.1.10
Listing raw device(s)
Device 0 (VID=12d1 and PID=1052) is a Huawei MTP device (ID2).
   Found 1 device(s):
   Huawei: MTP device (ID2) (12d1:1052) @ bus 1, dev 4

> mtp-connect
libmtp version: 1.1.10

Device 0 (VID=12d1 and PID=1052) is a Huawei MTP device (ID2).
Android device detected, assigning default bug flags

> ls /run/user/1000/gvfs
<empty>

> gvfs-mount -l
Drive(0): ST500DM002-1BD142
Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Volume(0): DiskD
    Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
Drive(1): TSSTcorpDVD-ROM SH-116AB
Type: GProxyDrive (GProxyVolumeMonitorUDisks2)

It seems to me that my android phone is detected as a valid usb device, but mtp is not connected.

I actually have re-install linux kernal as well, still no luck. Any idea what I should do ?

  • To me it seems the hardware and drivers are all good. Are you sure your UID is 1000? Do the ls like this run/user/$UID/gvfs instead of a hard "1000". – Rinzwind Feb 22 '18 at 9:40
0

Try using these steps:

  • Visit the detect Android phone on Ubuntu page and follow its directions
  • Change the USB PC connection in your phone from Media device (MTP) to Send Images (PTP).

I agree its not the regular practice, yet it worked for me quite well. Try if it helps else will try solving it in other ways possible.

0

The easiest way to solve the "use-case" of transferring files to or from and Android phone to an Ubuntu desktop wherein the out of the box functionality isn't working by default is Android File Transfer for Linux.

It just works!

You sound technical enough, so follow the steps here: https://github.com/whoozle/android-file-transfer-linux

A more dumb down step by step is written here: https://askubuntu.com/a/1111802/183131

0

If MTP is not activated on the phone, and adb is working, you can activate it with

adb shell svc usb setFunctions mtp

Not the answer you're looking for? Browse other questions tagged or ask your own question.