3

When I use libreoffice writer, every now and then my entire system freezes. Usually when selecting more than a few words of text, but it does not happen every time I select a paragraph (have not been able to reproduce the bug when I tried, but it happens often enough on important documents to be very annoying). EDIT: I am not talking about huge and complicated documents here: This has happened to files with less than one page of text, only a few formatting options (bold text and bullet points I think) without any pictures or graph or anything!

In the frozen state I can only move the mouse and interestingly the sound keeps playing, but I can't click anything or enter the console. (It's not the typical "libreoffice turning grey because it's overwhelmed" where you just wait until it passes. It's a complete freeze, and the only option is to press the power button.

I'm using Libreoffice version 5.1.6.2 on Ubuntu 16.04 LTS (kernel version 4.13.0-36-generic), with a Lenovo Thinkpad 13 (Intel i3 core, 16 GB RAM).

I've found similar problems described e.g. here...

However, the solutions mentioned in the previous threads don't seem to help me. I don't think I can "turn off transparency" in the writer (I'm not drawing any transparent areas there), and I don't think I have a NVIDIA graphics card. I tried to figure out the later:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)

What do you recommend? I would highly appreciate your help!

EDIT: I have the little system monitor running and as far as I remember, CPU was never too busy when the freeze occurred, probably below 15-20%. (Of course that display also stopped showing me more recent results when the system had frozen - but CPU-usuage definitely did not go up visibly right before the freeze).

UPDATE 1: I tried out the following:

Under System settings - Software & updates - Additional drivers, my only listed item is "Unknown:Unknown". The tag is, by default, on "do not use the device". I changed it to "Using Processor microcode firmware for Intel CPUs from intel-microcode (open source)".

I just worked half an hour on a libreoffice writer document and nothing froze so far! :)

UPDATE 2: Seems like the driver change is not really a solution yet. I worked another hour or so on a libreoffice writer document without problems at first. But then I selected two rows that I wanted to move in a table, and had a new type of crash: This time, the system only froze for a short time (same symptoms as above, could only move the mouse) but then it logged me out automatically and threw me back to the log-in screen. I suppose that's a bit better than having to shut down the computer via the power button... Still not solved though.

UPDATE 3: Working on libreoffice writer (same document with the tables in it that crashed yesterday) all day - no problems so far! So I definitely count this as an improvement!

  • Try the community flavour Lubuntu 16.04 LTS. You can try it live (booted from a USB boot drive). It has a light-weight desktop environment, which makes graphical tasks work much better in a computer with a weak processor or not enough RAM. (I checked the specs of Thinkpad 13 and found an Intel i3 CPU and 4GB RAM, which should be enough for standard Ubuntu, but ...). – sudodus Feb 22 '18 at 9:42
  • I do not think that is the problem. I have the i3 core, but with 16 GB RAM - just added that info to the description. (I can analyze large spatial datasets on this computer but not edit a simple text file...) – Simona Feb 22 '18 at 11:51
  • I agree that RAM size is not the problem. I suspect that there are problems with the graphics. 1. Try to turn off transparency according to what you discuss in your question; 2. Try with a lighter desktop environment, ultra-light Lubuntu or maybe medium light Ubuntu Budgie, Ubuntu MATE or Xubuntu. – sudodus Feb 22 '18 at 12:53
  • 1
    Are you working with a huge or very complicated document? What size is the file? Are there very big pictures or tables? Are there many other programs or documents open at the same time? Have you checked how much memory is used, and if your system is swapping? Have you checked with memtest that the memory (RAM) hardware is good? – sudodus Feb 27 '18 at 16:39
0

One alternative to launching a full blown word processor to edit a "simple text file" would be to use a lightweight simple text editor. There are several of these and examples are included with every Ubuntu release.

Notable GUI members of this class include gedit and leafpad and for the CLI include vi(vim) emacs(e3) and pico(nano)

Depending on what you are actually doing in the background it can make good sense to save resources by using more lightweight alternatives. I had an issue once where nautilus wouldn't start under a heavy system load using a slightly lighter weight file manager solved the problem for me.

  • I don't think the "weight" of libreoffice is a problem. (Not saying anything against gedit and emacs of course!^^) My computer handles other heavy programs fine (image manipulation, even analysis of large spatial datasets/GIS...) I wasn't doing anything in the background when the problems occured. – Simona Feb 27 '18 at 16:35
  • In that case, since I cannot duplicate this problem, perhaps you might edit your post to include the kernel version you are running via uname -a and the results of a memtest and a SMART test & the answers to this comment could also help us help you! – Elder Geek Feb 27 '18 at 16:52
  • I added the kernel version. I haven't run a memtest yet, I'll do that later tonight. Thanks for your continued support everyone! – Simona Feb 28 '18 at 15:34
0

In my experience with either LibreOffice5 or LibreOffice6, the size of the document or the particular operations within LibreOffice don't seem to matter much; the freezing of the software and/or system happens randomly.

To diagnose the problem, find out what process is guilty for the frozen graphics: I open a terminal (CTRL-ALT-F2) and run "Table of Processes", with command "top", to see what is running. At the top of the list, during the GUI freeze, Compiz is clearly shown hogging resources, at 100% or even 106%, sometimes relinquishing resources after 2 or 3 minutes lag. (For me, after a long delay when Compiz finally drops down to 10% CPU or even 0%, the fan audibly changes to a lower speed.)

If you want to wait, you may see the Compiz process drop off the list of the Table of Processes running. At this point, switch back to your GUI (ALT-CTRL-F7), and you may be able to continue working in LibreOffice. Basically, there's an interminable lag in Compiz, not a problem with LibreOffice, AFAIK.

If you want to kill the Compiz process, in the hopes it will re-start and restore without the freeze, you can try the "kill" command using the terminal and apply it to the Compiz PID. Get the current PID for the Compiz process from the left-hand column in TOP, then from the command line, run "kill -9 PID" then get back to the GUI (e.g. CTRL-ALT-F7). Sometimes a Compiz re-start in this manner will recover and make LibreOffice usable again (Eureka!), sometimes Compiz re-start will blank out the Launchbar icons (but LibreOffice will still be usable > save your work > reboot your system) ; more likely, Compiz re-start will freeze the whole system, requiring reboot e.g. switch back to terminal, run "sudo shutdown -r now" (If you have to reboot, hopefully LibreOffice saved your work > recover your work on the next session of LibreOffice).

The lag in Compiz is confirmed (for me) using different software: LibreOffice 5, LibreOffice 6, Firefox, etc. So again, it's not a problem specific to LibreOffice, IMHO.

There are many complaints about the latest CompizConfigSettingsManager (CCSM) update on AskUbuntu: Ubuntu 16.04: Compiz uses way too much cpu 2/15/18 compiz update broke unity Unity Top Bar and Launcher disappeared Feb 24/2018

I tried switching to LOWGFX mode, using CCSM, but the problem with Compiz persists, e.g. when using LibreOffice5.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.