Long story short, I had to move a running bugzilla version from Windows into Ubuntu. I had the a fresh installation of bugzilla running yesterday, but when I tried to bring the data in, the css and scripts where not displaying the site correctly. I tried setting the owner and user of the files and directories, I found that apache was having rights issues. I tried getting help from bugzilla, but no one replied with the correct fix. I thought that if I remove apache and install it back, it would fix the security problems. Well, was I wrong...!

I have tried a good 4-5 times to,

sudo apt-get purge apache2 apache2-utils apache2.2-bin apache2-common
sudo apt-get autoremove
whereis apache2

and then used

sudo rm -rf /etc/apache2 

on any directory that resulted from the whereis command. Now, I can not install apache2 on the system. Here is my last install try:

$ apt-get install --only-upgrade apache                        2
Reading package lists... Done
Building dependency tree
Reading state information... Done
apache2 is already the newest version (2.4.18-2ubuntu3.5).
0 upgraded, 0 newly installed, 0 to remove and 105 not upgraded.

$ sudo service apache2 restart

returns nothing.

closed as off-topic by user535733, Zanna, Rinzwind, Elder Geek, George Udosen Feb 24 '18 at 17:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – user535733, Zanna, Rinzwind, Elder Geek, George Udosen
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please edit your question to include the complete output of sudo apt update and sudo apt upgrade – user535733 Feb 21 '18 at 23:06
  • Well, is doing a lot of upgrade... give me a sec.. Also, it's a log of data, how can I paste here where I can only paste 500 characters or so? – jicman Feb 21 '18 at 23:15
  • Use paste.ubuntu.com – user535733 Feb 21 '18 at 23:17
  • Here is the update, link – jicman Feb 21 '18 at 23:20
  • sorry, reversed... here is the update link the other one was the upgrade. Apologies... – jicman Feb 21 '18 at 23:25

This is what I did to fix the problem:

apt-get remove apache2*

then followed by

apt-get install apache2

  • Can be done in one step: dpkg-query -Wf '${Status;1} ${Package}\n' 'apache2*' | sed -ne 's/^i //p' | xargs sudo apt-get install --reinstall – David Foerster Feb 23 '18 at 0:02
  • By the time I type that, those two commands above would have been completed. :-) – jicman Feb 23 '18 at 20:19
  • Fair enough.... – David Foerster Feb 24 '18 at 1:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.