0

I'm trying to dual boot Kubuntu on my Acer Swift 3 (Win10 already installed), however, after every time I reboot after installing, it boots straight to Windows. Pressing F12 displays Windows Boot Manager as the only option.

I've already tried the following:

  • Installing Kubuntu alongside windows 10 from live USB, bootloader on sda

  • Reinstalling with bootloader on sda6 (Linux install partition)

  • Running Boot-Repair from live usb

  • Doing bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi (from tutorial somewhere)

None have worked, every time it only boots straight to Windows, no GRUB. Perhaps the BIOS can only run the Windows Boot Manager?

Any suggestions?

~~~~

My BIOS is set to UEFI boot w/secure boot off. Using Legacy only displays something like No bootable disk detected. Insert bootable disk and press any key to continue

0

Turns out the problem was that the EFI was disabling grubx64.efi from booting. By entering the security tab in the bios and under the add new file to efi option, added the grub file.

0

In my case the solution was to change the order of the EFI in the BIOS: It showed Windows as the first, but I cold move the Kubuntu partition upwards, save and reboot. From then on it showed the GRUB loader with all options again. Me happy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.