1

I have looked everywhere and while I've found some similar issues, I have yet to see an actual solution.

I installed Ubuntu on an Acer Aspire Switch V11, which works just fine except for one thing: it does not seem to see the battery at all. Included is a screen-shot I took with the laptop unplugged. Nothing changes when I plug it in either. Eventually the laptop will shut down and I have several times lost work because of this, so I'm hoping someone might have an idea.

Screen-shot, unplugged:

enter image description here

0

You could try this, some people got helped by this. Discharge the battery, turn of the computer, take out the battery, press and hold the power button for 20 seconds, wait 2-3 days, and then connect the battery again. https://www.youtube.com/watch?v=yEZcmVx84Ps But some other guy says wait for 2-3 minutes.. https://www.youtube.com/watch?v=TZBMp3Dqo0A

You could also try to update bios. I did that yesterday, and that solved my problem. (The problem I described in the post deleted by "karel, Seth". My problem was not exactly like your problem. I do not know if it possible to get the post back.)

https://www.youtube.com/watch?v=Oyy1uKIPB6s

0

I have the same laptop and unfortunately there aren't new BIOS Updates yet. I reported this bug some months ago here https://bugzilla.kernel.org/show_bug.cgi?id=198177

EDIT: Someone made a kernel module, i tested it and WORKS! https://github.com/jfrimmel/Acer-Switch-Battery-Module

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.