I have a Wacom Bamboo that works out-of-the-box on Ubuntu 11.10 (even pressure). The problem, though, comes when using it on VirtualBox.

If I don't allow VB to access it, it recognizes the tablet as a mouse and works well (the same as when you plug the tablet the first time in Windows [normally, not on VB] and don't install the drivers). However, when I install the drivers and allow VB to access the tablet via "USB devices" it becomes really slow. I get pressure-sensitivity in Photoshop, but in exchange of a lag of seconds.

The question is.. is there a chance to solve this or is this something inevitable when using a tablet through VirtualBox?

Sorry, forgot some info:

Virtualbox version is 4.1.8 (Oracle version, not the OSE), guest is Windows 7 (though I think it happened the same in XP).

  • Do Your Windows apps work normally or they are slow too? – Misery Feb 3 '12 at 9:32
  • 1
    It's only happening in Photoshop, though I don't know if it happens in the other apps and it's not noticeable. MAybe it's a RAM issue? – Cmorales Feb 3 '12 at 13:48
  • ok, did You give Your Windows more ram in VB settings? – Misery Feb 3 '12 at 16:36
  • my guess is that on VB photoshop cannot use hardware support for Wacom device. – Misery Feb 4 '12 at 12:10
  • I think I aimed at the wrong thing. More than a RAM issue (it has 2GB and shows a lot unused) it looks more as a graphics issue. Something related to the video memory, maybe. Can you explain what do you mean with hardware support? Thanks – Cmorales Feb 5 '12 at 13:43

Try to use the options in Virtual Box like:

Settings -> System -> Enable... (tablet)

Also ensure you have installed VB Guest Additions and the VB extension pack. And be sure to enable USB 2.0 support in USB options

enter image description here

Please note that Windows 7 will recognize your tablet as a touch interface and you will not see the mouse moving (although you will still be able to click). To solve this, you must disable mouse integration.

| improve this answer | |
  • I have the same as you there (appart from the UTC thingy, though I don't think that matters). 128MB of video memory, 2D and 3D enabled in "screen" USB enabled, with USB2.0 enabled too. I tried setting a filter (I read about it somewhere here) with no luck either. In system, I have the VT-x/AMD-V thing enabled, but not the other one (I don't know how to translate it from the Spanish "paginación anidada"). – Cmorales Feb 8 '12 at 8:32
  • But did You install VB extension pack? In my case that solved the issue. Google translator says that "paginación anidada" is "nested paging". That might be useful but I don't think that is the issue here. Could You give the screen shots of Your settings? Especially memory and processor – Misery Feb 8 '12 at 8:39
  • 1
    Well, maybe it is not Ubuntu/VirtualBox/Windows issue. Check this link please – Misery Feb 8 '12 at 8:48
  • 1
    Weird, now it's working :S I need to disable mouse integration, though. I might have set that config when I was trying to solve the problem but not tried without mouse integration. I am going to wait to check if the problem shows up again and, if not, mark your answer as valid. – Cmorales Feb 8 '12 at 9:11
  • 1
    Yes, it is so far. I am going to edit your answer with a remainder to disable mouse integration. – Cmorales Feb 8 '12 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.