3

On Ubuntu 16.04.3 LTS

Pulseaudio causes Xorg to use 100% CPU.

After disabling autospawn in /etc/pulse/client.conf and killing pulseaudio CPU immediately drops to acceptable level. After restarting pulseaudio Xorg returns to 100% CPU.

pulseaudio --kill
pulseaudio --start

Installed versions:

pulseaudio 1:8.0-0ubuntu3.7
xorg       1:7.7+13ubuntu3
nvidia-390 390.30-0ubuntu1 

How to fix this?

  • 1
    I wonder how did you track the problem to the pulseaudio for the first time? I have absolutely the same trouble – valignatev Sep 1 '18 at 17:36
1

Could you assure set in

/etc/pulse/daemon.conf

Values

high-priority = no
realtime-scheduling = no
  • I've tried setting both to "no", but it had no effect. – Jos Huisken Feb 22 '18 at 21:27
  • Worked for me on Arch Linux though, so thanks! – valignatev Sep 1 '18 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.