0

I know this sounds like some other posts on here but I have tried the solutions suggested by them and nothing seems to work. I had previously used this MacBook Air with Ubuntu 15.04 a couple of years ago and I got the wifi working quite easily but I am having real problems this time.

The wifi card is detected and recognised but will not find any SSIDs. I am currently using a USB wifi card but this MacBook Air only has 1 USB port so this is a pain! At the moment the wifi menu shows the Broadcom BCM4321 as disconnected. I have installed the firmware-b43-installer and checked to see if it is hard or soft locked (it is not). It is shown in the alternative driver section as using the Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source(proprietary). Wifi worked fine on this MacBook both in Mac OSX Snow Leopard and in Windows 10. I do have a copy of the Boot Camp drivers if these are any use...

Following advice in another similar question, I have disabled the alternative driver. Currently iwconfig gives:

    $ iwconfig
     wlan0     IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:off

rfkill does not show that anything is blocked.

    $ sudo lshw -c network
    *-network               
           description: Network controller
            product: BCM4321 802.11a/b/g/n
            vendor: Broadcom Limited
            physical id: 0
           bus info: pci@0000:02:00.0
           version: 05
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
            configuration: driver=b43-pci-bridge latency=0
            resources: irq:16 memory:90300000-90303fff
       *-network
           description: Wireless interface
           physical id: 2
           logical name: wlan0
           serial: 00:1f:5b:e2:f5:a2
           capabilities: ethernet physical wireless
           configuration: broadcast=yes driver=b43            driverversion=4.13.0-32-generic firmware=666.2 link=no multicast=yes         wireless=IEEE 802.11


    02:00.0 Network controller [0280]: Broadcom Limited BCM4321 802.11a/b/g/n [14e4:4328] (rev 05)

    dpkg-query: package 'bcmwl-kernel-source' is not installed and no information is available

I uninstalled bcmwl-kernel-source as recommended in the instructions.

  • Did you follow the extensive how-to here? askubuntu.com/questions/55868/… I think you have installed the wrong driver. – chili555 Feb 20 '18 at 0:36
  • Yes I did, I have tried the various fixes, purges and installs. None of them give me an internal wifi card able to find and connect to a network. I probably have at some point installed the wrong driver, also probably the right driver and there could be some sort of conflict. – Simon Baldwin Feb 20 '18 at 12:09
  • Following the how-to, what is your device? lspci -nn -d 14e4: Is bcmwl-kernel-source installed? sudo dpkg -s bcmwl-kernel-source Edit your question to add the results. – chili555 Feb 20 '18 at 14:54
  • I have added the information as suggested. bcmwl-kernel-source is not currently installed as I removed it as recommended in some of the posts. The wifi did not work with it installed either. – Simon Baldwin Feb 21 '18 at 11:50
0

The real answer here is to install via in BIOS mode rather than EFI. In EFI mode, the wifi card is not "approved" hardware. When I started again using BIOS instead of EFI, it all installed without a problem. The wifi worked straight away but using the wl driver.

I installed the b43 installer and it automatically found and installed the correct b43 driver. The wifi is now working fine!

I found the solution on

https://forums.linuxmint.com/viewtopic.php?f=53&t=223778&sid=d4ad5a498dcd5dfed97324e11f14cccf&start=20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.