Successfully deployed MAAS 2.3 and 4 nodes have been commissioned and are ready to deploy. Have both private and public VLANs connected to each node.

Followed instructions for setting up production openstack here: https://www.ubuntu.com/download/cloud/build-openstack

When I run conjure-up (v. 2.5.2 installed with snap)

Spell Selection - OpenStack with NovaKVM

Leave SSH public key path as shown

Deploy all 16 applications in openstack-base

It runs through initializing juju controller and shows deploying on a single node in maas until I see deploying machine script and then it stalls forever (hours) and I get the following errors:

Errors that show up under "Events"

Node post-installation failure - 'cloudinit' running config-apt-configure with frequency once-per-instance
Node post-installation failure - 'cloudinit' running modules for config

The node status shows ubuntu 16.04 LTS after the errors are posted.

Edit: I have tried to start over using conjure-down however I get the following error... Unable to list controllers: /bin/sh: None: not found

$ juju destroy-environment
returns ERROR unrecognized command

Tried to remove conjure-up with

$ sudo snap remove conjure-up

However the cloud controller used previously is still listed when reinstalling with

$ sudo snap install conjure-up --classic

Any idea what I am doing wrong here? TIA

up vote 0 down vote accepted

There were 2 issues. Hopefully this helps someone who is burning hours trying to figure out MAAS networking. YMMV

Although both the private and public VLAN's were enabled and set up under the subnets tab in MAAS, I needed to route the private VLAN (subnet) to the external internet (to download packages for deployment) and to an upstream dns (to resolve package ip addresses) accessible within my routed subnets. The dns needed to resolve quickly to eliminate timeout issues as well.

I am sure there are several ways to do the NAT'ing including using iptables.

One other issue, when I tried to let MAAS manage the public subnet, (DHCP, Auto-assign) it wouldn't assign a dns or gateway although it did assign an IP, and without dns/gateway nothing was getting routed on the public subnet (host/address not found/unreachable).

More documentation on how MAAS actually works behind the scenes relating to networking would be beneficial IMO.

My Solution

I enabled the private subnet route along with an internal upstream dns in my upstream router, which I believe makes it a flat network and no longer private. The public subnet is unconfigured in all nodes.

MAAS handles DNS and provides DHCP on the private subnet for my scenario Additionally, the private subnet still had to be both routed to an external internet and upstream DNS for deployment of nodes.

To test in MAAS I deployed a single Ubuntu node and ping'd the host name from the MAAS node.

After successfully pinging the Ubuntu node, I ssh'd into the Ubuntu node from the MAAS node using the host name and then I then ping'd google.com from within the deployed Ubuntu node.

This may not be the correct way, but as no one answered, I found a method that is working.

I would prefer a split-network with the private subnet being truly private and without using my MAAS node for routing to the public internet if there is a way.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.